4

I have an Macbook Pro 13" 2018 as my portable/home computer and iMac in the office as workstation. When I bring the Macbook to the office and it connects to office wifi, it keeps waking up in the bag, draining the battery.

I tried to reinstall macOS, everything was ok until I signed in with my Apple ID, so I suppose it's due to handoff/continuity (only thing I have installed now is iStat menus and I'm signed to iCloud, nothing else, clean OS.)

I can lose almost full battery in one day in sleep if I don't turn off wifi and also the Macbook gets very hot and it even reboots itself because of the high temperature.

cpu usage graph

I use macOS 10.15.2 on both computers.

How can I prevent this and still have handoff/continuity enabled?

4
  • Periodic wake ups are normal with Power Nap. Is it staying awake and not going back to sleep? – Allan Jan 16 '20 at 18:26
  • Something is definitely up here @Allan too many people are getting massive power drains in closed clamshell, the nap settings are the same afaik but the energy expended has ballooned. I doubt it’s just Catalina but it could be EFI issued when Catalina happens and doesn’t roll back like this report. – bmike Jan 16 '20 at 18:38
  • I agree @bmike - someone was commenting to me recently that they keep forgetting to charge their MBP because it's always dead - now I'm thinking otherwise and confirming my thoughts that upgrading to Catalina is not a wise idea for production machines at this point. I'm just really interested in this question and answer. – Allan Jan 16 '20 at 18:42
  • @Allan both are turned off for battery and also power adapter. As you can see from the chart, it's waking up and going to sleep OK, but too often. Well I don't have problems like others, it's doing only when my MBP and iMac are on same wifi so I think it has something with continuity. I can have MBP at home for whole day and loose 1%. – Leachim Jan 16 '20 at 21:11
1

Power Management is the culprit.

You should use the pmset command to see what power management has been doing. In Terminal, the basic command is

pmset -g log

But that gives you all the power management events since last boot time. You can reduce this with judicious use of grep. I have used both of these (with similar results):

pmset -g log | grep -e "Wake from" -e "DarkWake" -e "due"
pmset -g log | egrep "\b(Sleep|Wake*|DarkWake|Start)\s{2,}"

Power Management has about 20 settings that can be changed by an admin user. To view the settings (they will be different when on battery and power):

pmset -g

For my issue, which looks similar to yours, I changed the tcpkeepalive setting. With this enabled (value = 1), the MacBook will frequently wake up due to network events.

To change turn off tcpkeepalive use the Terminal command:

sudo pmset -b tcpkeepalive 0

The -b is to set for when running on battery.

I have also tweaked a few other settings like standbydelayhigh, but this is purely tweaking.

This is based on my experience with a MacBook which would lose too much (I thought) battery whilst closed overnight.

You may find these two links helpful: How to Fix macOS Mojave Battery Draining Issue and man pmset.

Note that I have not changed hibernatemode from the default value of 3. Many (including the linked article) discuss changing it to 25 which I do not recommend with recent (last 4 years) hardware and macOS version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .