2

I have an iMac Pro. No camera shows in the system report under Camera, just under USB. My microphone is also not working. I tried resetting the NVRAM but it didn't solve the problem.

Facetime Camera in the macOS system report under USB Device

What should I do to fix it?

2

The T2 chip is involved in running the camera and microphone to a major extent such that the old way to troubleshoot this need an update.

First, consider powering everything off and then disconnecting from power for 15 to 30 seconds to let the SMC and T2 do a complete cold boot. Portables have a more involved SMC reset but Mac Pro and iMac Pro are easy to reset.

Next, consider getting diagnostic run from Apple if you have that option and if not consider connecting to the internet and running a reinstall of macOS to give everything a chance to update. Reinstalling the OS online and not from a saved installer or offline image ensures you have a chance to get caught up on EFI and firmware and bridgeOS updates.

In addition to the os, the T2 and the EFI Get updates only when you install the OS. This won’t intentionally erase anything, but I like to back anything important up just in case.

Lastly, take it in for a physical repair.

| improve this answer | |
  • Hi, I've done everything, including new OS install. I guess it's a hardware failure in this case. Bummer. – Ciprian Tepes Jan 21 at 18:31
  • We sent our first iMac Pro in for a T2 issue as well last month. Been a perfect line for our small deployment until now. – bmike Jan 21 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .