I'm trying install react-native-cli in My MacBook. Executing this command in my terminal

npm install -g react-native-cli

Getting this error

npm WARN checkPermissions Missing write access to /usr/local/lib/node_modules
npm ERR! code EACCES
npm ERR! syscall access
npm ERR! path /usr/local/lib/node_modules
npm ERR! errno -13
npm ERR! Error: EACCES: permission denied, access '/usr/local/lib/node_modules'
npm ERR!  [Error: EACCES: permission denied, access '/usr/local/lib/node_modules'] {
npm ERR!   stack: "Error: EACCES: permission denied, access '/usr/local/lib/node_modules'",
npm ERR!   errno: -13,
npm ERR!   code: 'EACCES',
npm ERR!   syscall: 'access',
npm ERR!   path: '/usr/local/lib/node_modules'
npm ERR! }
npm ERR! 
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR! 
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/kishore/.npm/_logs/2020-01-16T01_34_30_715Z-debug.log

in my which node


My npm get prefix


Help me out fix the issues.

  • What are the permissions of /usr/local/lib/node_modules? – nohillside Jan 16 '20 at 6:41
  • Pemission drwxr-xr-x 4 root wheel 128 Jan 16 12:46 node_modules – Kishore Jan 16 '20 at 7:22

Finally found the solution after many tries

sudo chown -R $(whoami) /usr/local/bin

After that running working fine without any issues.

npm install -g react-native-cli

Now it's working fine.


Have you tried sudo npm install -g react-native-cli?

  • What does this do and how does it adress a permission issue? – nohillside Jan 16 '20 at 6:41
  • if I tried this sudo also getting this error gyp ERR! configure error , gyp ERR! stack Error: EACCES: permission denied, mkdir '/usr/local/lib/node_modules/expo-cli/node_modules/fsevents/build' – Kishore Jan 16 '20 at 7:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .