1

I bought a month ago MB Pro 16 2019, and I'm trying to use it with the Dell TB16 docking station.

I've enabled it with Thunderbolt3Unblocker and all seems to be working fine except external display(HDMI, other display ports probably are not working) which is randomly flickering(every few seconds) with green or noise. I've tested it with 2 monitors and TV, always the same.

TB16 with other laptops works well. I've tried to use some instructions found on the internet about resetting NVRAM or so but nothing helped. I've seen some green flickering on internal display too when I was watching a movie on fullscreen, but it was less common than with external display on TB16. Also, I didn't notice that the issue on an external display connected via HDMI dongle to MB.

Do you have any idea how to fix it?

0
3

The developer of "Thunderbolt3Unblocker" lists this as a known issue and recommends a firmware update on the TB16 which apparently helped some users.

Source: https://github.com/rgov/Thunderbolt3Unblocker/issues/28

video output does not work. Unfortunately, this is out of scope for this project.

2
  • Thanks for your reply. I've seen that tip and have updated firmware on TB16, because before that HDMI output was not working. Like I described above, after update it is working, but with random external screen flickering (green or noise screen)
    – belial
    Jan 16 '20 at 9:36
  • 2
    @belial - did you ever get this to work without glitching every 6 seconds or so?
    – ThinkCode
    Jun 14 '20 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .