I used to be able to type something into the iTunes search bar to filter the songs. You could click on a song, clear the search, and focus would stay on that song/album's position. I've since added a good amount of music to iTunes, and now when I clear the search box it moves to the top of the list every time.

This is really annoying. I'm pretty sure it has to do with surpassing a certain number of songs (I'm at 10,145) because it still works in smaller sized playlists (e.g. one with 3,000 songs).

I even tried regenerating my iTunes library from scratch (removing the Music/iTunes folder, relaunching, and re-importing everything) and the same behavior occurs.

Does anyone know how to get this functionality back? Is there a setting somewhere I can set? Or is this just a bug with iTunes (or maybe Cocoa?)


I had the same problem (with a similar number of songs -10742) after clearing the search box. What worked for me was clicking the curved arrow button on the right hand side of the little box, at the top of the iTunes screen, that shows the currently playing song, and its progress. This button returns the screen to the library location of the currently playing song. I'm currently running iTunes 10.5.3 on a 64-bit MacBook Pro. Hope this helps.

  • Yep, this somewhat achieves the goal. Still would love to have the old functionality back; it's useful while doing something like creating a playlist without constantly changing the song as you scroll down – macca1 Feb 4 '12 at 21:38

I complained to Apple care today about this same problem and the iTunes expert that I talked to had never heard about it until I told him. After discussing, he and I both suspect that it's a bug that came across in an iTunes update last week. I don't think the size of the library is a factor, as mine has been at 80,000+ songs for the past 3 years and had never had this problem until this past weekend. If your problem occurred prior to this update, then it may help to pinpoint which update caused it.

Hope this helps.

  • My problem happened well before the update last week. I think it's a bug with the UI framework that iTunes uses (which is I believe is Cocoa) – macca1 Mar 30 '12 at 21:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .