7

I have several old MacBook (MacBook2,1 units, from 2006) that have been running Mac OS X 10.6 Snow Leopard just fine, and been in use to teach a robotics class.

I know we used them in December, but a week ago (in Jan 2020) they would not boot up, but would kernel panic instead.

They have Mac OS X 10.7 Lion on their recovery partitions, which boots up just fine. I can boot into single user mode. I can boot in safe mode. Booting in verbose mode ends in an error (below). Unfortunately, I can't remember the password for the admin account, and when I tried to reset it (by saying the first boot process wasn't done), it kernel panicked before I could create a user.

In wondering if perhaps a cryptographic signature had expired, I set the date back a couple of years on one of them, but that didn't help.

I just re-installed 10.6 (.3) on one of the units, and the output, in verbose mode, looks very much like it did on the other units. (This photos is from one of the other units; I think it was running 10.6.7 or .8).

enter image description here

Any idea what I can do to get these units back into operation?

  • they won't run Mac OS X 10.7 without more RAM, and I think they are too new for 10.5
  • I'd rather not install Linux or Windows on them, although it is not beyond the pale. The software is only experimentally supported under Linux, and I don't have Windows licenses for the machines.
  • I don't need them to connect to the internet, and would be happy to disable WiFi (which is implicated in the stack trace). I tried disabling the .kext but couldn't figure out which file it is.
  • Apple periodically does kernal updates without telling us. I lost Lion boot that way. You may have had a similar experience. This makes me unhappy, but there does not seem to be an accepted protocol for rolling back kernal changes. -Shame on Apple. – Wayfaring Stranger Jan 15 at 2:31
  • 3
    @WayfaringStranger ...huh? I'm pretty darn sure Apple isn't silently pushing autoupdates to ancient kernels without incrementing the version number. – Wowfunhappy Jan 15 at 3:56
  • Leopard 10.5 was released in 2007: the 2006 MacBook originally came with Tiger 10.4.8: so you might possibly try one of those. – benwiggy Jan 15 at 7:25
  • "I tried disabling the .kext but couldn't figure out which file it is." - in SL installer it is /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros.kext. Perhaps try deleting all of IO80211Family.kext and rebuild kernel cache. – lx07 Jan 15 at 12:34
  • @Wowfunhappy I've seen it happen a couple times. Maybe Apple puts out warnings, but they are not always easy to find. They really want us to use the latest and greatest. That can cause trouble for older Macs. My earliest Mini is 2005. Keeping it at a clean 10.5.11 can get tricky. BTW, it does NOT face WiFi or internet. – Wayfaring Stranger Jan 15 at 12:37
6

That photo says the kext (driver) for the Atheros airport card is what's causing the kernel panic.

There's a very simple way to disable this kernel extension, although it's terribly hacky: go into /System/Library/Extensions/, and rename IO80211Family.kext to IO80211Family.kext.bak.

Afterwards, go into the Terminal and run sudo kextcache -system-caches to rebuild the kernel cache.

On newer systems, this would require disabling SIP and/or remounting the root partition, but this is Snow Leopard.


Since you don't need the wifi, the above may be enough for you, but I'm at a loss as to the root cause of the problem—why would this kernel extension suddenly begin panicking? Safe mode, recovery mode, and single user mode likely don't load this extension, so the fact that those work makes sense, but how could the problem have suddenly appeared on two different machines?

The only other suspicious thing is that the computer kenel panics right after loading the lego mindstorm kext (com.ni.Fantom.nxtfwdl). That kext isn't listed in the backtrace at all, so it shouldn't be the culprit, but... if you upgraded the mindstorm software recently, you might want to try downgrading it. Or, you could try removing the mindstorm software altogether, but it sounds like that would render these machines useless to you.

| improve this answer | |
  • Thanks for the reply. This same issue is affecting 8 machines. A fresh install of Snow Leopard (without the Mindstorms firmware) still kernel panics on the WiFi driver. – Clinton Blackmore Jan 15 at 5:07
  • @ClintonBlackmore And did you try renaming the wifi kext? (And rebuilding the cache). I do wish I had something that was less of a hack, but if you don't need wifi, that should stop it from loading. – Wowfunhappy Jan 15 at 14:12
  • just tried it. I logged in in single-user mode, mounted the drive, and renamed the .kext. sudo kextcache -i / was not interpreted as a valid command, but sudo kextcache -system-caches did the trick. I've booted up into the UI. It's beautiful! Many thanks. – Clinton Blackmore Jan 15 at 17:38
  • @ClintonBlackmore Thanks, I've updated the answer in case anyone else comes along. The syntax for rebuilding caches must have changed at some point. – Wowfunhappy Jan 24 at 14:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .