1

I need to copy "Network Diagnostics.app" into the Mojave Core Services library.

Running "csrutil disable" from terminal doesn't work, says you have to run from Recovery OS. I don't know if I have Recovery OS or not, only Mojave is installed.

Giving Finder "Full Disk Access" under "Security and Privacy" threw errors when I tried to copy the file (a circle with a line through it appeared when I tried to drag and drop).

Giving muCommander (a 3rd-party freeware file manager) Full Disk Access didn't work either, "unable to write to directory" error.

I read that this can be done through the command line, what would the syntax be? Is this correct:

sudo cp \Desktop\"Network Diagnostics.app\MacintoshHD\System\Library\CoreServices\Applications\

Seems strange that I can't run a program as Administrator, but I understand this was a deliberate decision by Apple. Is there a way to accomplish this?

4
  • Let’s address mu commander and full disk access in a separate follow on. The protection and system mod is pretty large sequence of my overview answer didn’t get you where you need to proceed.
    – bmike
    Jan 14 '20 at 4:27
  • 1
    Are you referring to the Network Diagnostics.app from Sierra, which was removed in High Sierra? Have you tested to see if the app will even work on Mojave? It reportedly won't even work on High Sierra: <discussions.apple.com/thread/8098137>
    – TJ Luoma
    Jan 14 '20 at 7:00
  • Yes--but not so fast. The discussion you refer to doesn't say that at all. There are instructions on using the app, but first you have to copy it to CoreServices. They don't say it doesn't work. The app does not run from the Desktop in Mojave. I cannot, at the moment, copy it to CoreServices, which is the reason for my question. According to that discussion, to work the app has to be in CoreServices/Applications to work.
    – user26732
    Jan 14 '20 at 9:13
  • It may well be that Network Diagnostics.app will not work when run from CoreServices/Applications. But the discussion you refer to doesn't say that at all, and I can find no specific reference anywhere else apart from instructions on how to install the program there. But they did not include instructions for copying to this location n Mojave.
    – user26732
    Jan 14 '20 at 9:26
1

Root isn’t what you need, SIP must be disabled if you desire to modify the system files while booted from the same system as the files to be edited.

A centerpiece is the protection of system-owned files and directories against modifications by processes without a specific "entitlement", even when executed by the root user or a user with root privileges (sudo).

https://en.wikipedia.org/wiki/System_Integrity_Protection

macOS Recovery is part of the built-in recovery system of your Mac. First, boot to recovery, then open terminal from recovery and run sudo -s to become root. Then you are clear to make modifications to the normal system on the Macintosh HD volume.

You could also run the disable from recovery and restart it you want to opt out of protection indefinitely and not just temporarily.

I’m generally not doing that but your system, your call totally.

2
  • I'm in Mojave, not Sierra. Sudo -s doesn't give me root access in Mojave.
    – user26732
    Jan 14 '20 at 5:02
  • Thanks for spotting that. Doesn’t matter for the answer, but I should correct it with an edit. I fear I wasn’t clear - sudo -s is root, but root isn’t what you need to make the change you seek. It’s a little semantics, but system integrity restriction is what’s preventing you from modifying the /System and not posix/root/admin permissions on the filesystem.
    – bmike
    Jan 14 '20 at 5:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .