34

I have an Logitech MX Master mouse that comes with a program to adjust it's settings called Logitech Options. I use this to adjust the issue many people have a mac: you wanna scroll with trackpad the 'natural' way, but with the mouse wheel you want the reverse. In Logitech Options you can configure these two separately:

Logitech Options menu

However after every times the MacBook sleeps for a while the settings don't apply any more. They are still set correctly, but I have to change them and set them back every to for the settings to apply again.

This is an issue on my current MacBook Pro (2019 model), not on my previous one (mid 2015). I run MacOS Catalina (10.15.2)

How can I fix this?

4
  • 1
    One clue I noticed is whenever the mouse doesn't work 'right' on a bluetooth connection, the two little icons at the bottom of the screen showing the bluetooth and battery life will be greyed out. Switching over to my unified receiver seems to work (but I have issues with mine). Often a full reboot will correct it. I don't know what it means, it just feels like a clue. Mar 3 '20 at 14:09
  • I've used 5 Logitech mice over many years across 4 Windows PCs. Logitech Options has never once remembered settings when setting up a new machine. EVER.
    – niico
    Nov 2 '20 at 13:15
  • the solution in this post fixed the issue for me : apple.stackexchange.com/questions/383838/…
    – Stephane
    Mar 18 at 21:00
  • I posted a "bug report" to apple a few years ago over this exact complaint. First they responded "It is by design that the Mouse & Trackpad scrolling preference is shared." Then after I explained why I thought it was bad design, they said "Thank you for your feedback, it is noted. Engineering has determined that there are currently no plans to address this issue." Read into that what you will, but my take on it was "Do things the apple way with apple devices if you want them to work. We don't care about third party stuff."
    – shanemgrey
    Jun 25 at 17:56

11 Answers 11

12

For me it happened a single time and I just put the macbook to sleep and wake it up again. The options setting come back!

[Update] Today it happens again and the sleep-and-wake-up doesn't work this time. I switched off the mouse and switched on again, and the options are back!

3
  • Thank you @Sheng! For me, a simple Mac Sleep and wake-up fixed it! This happens about once a week for me, and only restarting the mac fixed it. But this is much faster!
    – stwr667
    Feb 9 at 2:39
  • I am experiencing the same thing. Weird but restarting once a week kinda at the limit I can bear so still keep using it...
    – Sheng
    Apr 20 at 15:59
  • OMG! I've been restarting my Mac all this time! Thank you for this! Logitech software sucks.
    – FrancisV
    Jul 26 at 21:09
12

Open Activity Monitor and stop Logi Options Daemon. This will restart it.

1
  • This is the most reliable way to make it work again for me. Aug 18 at 22:07
5

Open a new terminal and write:

kill $(ps aux | grep LogiMgrDaemon.app | awk 'FNR == 1 {print $2}')

This command search the PID of the Logi Options Daemon and kill it's execution, next automatically the daemon will restart and restore the normal behavior.

2
  • 1
    You can also just do killall LogiMgrDaemon. But for me right now this nor none of these other options are working. I've even removed the mouse from bluetooth and re-added it, restored defaults and then restored a backup, etc. The one thing that is consistent, though, is the icons at the bottom of the window are gray so I think for some reason the mouse is just not being recognized or picked up by the Logitech Driver.
    – B. Morris
    Mar 6 at 18:33
  • Great tip, this worked! I usually have to restart my workstation, but this is much better 🙂
    – jidicula
    Jul 9 at 18:08
5

This is a bit embarrassing but downloading the newest version of Logitech Options solved the problem (...for a month, but again the app is not stable.)

4
  • 4
    Well shit... now the problem is back :(
    – Herman
    Mar 4 '20 at 9:57
  • Yeah. I installed this software on one Mac and promptly decided I couldn’t run it anywhere and uninstalled it. I’ll forego any customizations in Logitech. It’s a shame since the hardware seems great. The Mac software, lacking severely for me in usability and reliability.
    – bmike
    Oct 7 '20 at 11:34
  • The only software I’ve been happy with on macOS to manage USB devices is usboverdrive.com
    – bmike
    Oct 7 '20 at 11:38
  • Big Sur with Logi Options downloaded yesterday. Glitchy af, so they haven't fixed anything. Oct 12 at 9:33
3

I have Catalina and M720 Triathlon mouse and exact the same problem. The newest Logi Options won't help. What I noticed though is that I don't need "to change them and set them back every to for the settings to apply again." Just restarting the Logi Options app fixes it. BTW the settings are kept even if you close this app. So selecting "Open at Login" in the Logi Options dock icon's options also assures it works after the reboot.

Now, I tried to reproduce the issue by putting Macbook to sleep and checking whether the settings were kept or not after the wake - and they were - even with Logi Options closed.

If it happens again seems the only option will be a script opening the Logi Options after each wake.

1
  • 2
    ...and today it happened again - without any apparent reason - just after some time of normally working. What's sad is neither restarting the Logi Options nor re-applying the settings helps, looks like I need to at least log out to get it working again aarrgghh Apr 5 '20 at 10:39
3

I had the same issue and the solution below fixed it for me :

macOS (Catalina) Disabled Input Monitoring

« I ran into this with Logitech Options. It wasn't showing up in Input Monitoring. To fix this, I had to see where else it was and remove it. Then reboot.

In my case, I found Logi Options and Logi Options Daemon in Accessibility.

Click the lock icon Enter admin password Select the app to remove Click the minus sign (-) button Repeat for other related apps Reboot Now, when you log back into macOS, you will be prompted to allow the new permissions. This should add the app to Input Monitoring.

macOS setting dialog of Keystroke Receiving of Logi Otions

3
  • Thank you for those references but is recommended that one also clearly writes down in her or his reply the steps suggested in those references as solutions in addition to the internet addresses. This is recommended because the addresses for the web pages referred to may change or the sites may be taken down in the future.
    – Alper
    Mar 19 at 10:26
  • Only thing that worked for me! Thanks. Apr 22 at 13:27
  • I didn't have to do most of the steps outlined here. Logi Options Daemon was listed in the Input Monitoring section, but Logi Options was not. I simply clicked the + and found Logi Options in the Applications folder to add it to this list. After that the custom settings from Logi Options program started working again.
    – shanemgrey
    Jun 25 at 17:39
1

I have been using a M557 for the last ~ 2 year gem of a mouse never an issue. I bought a M590 yesterday (multi device silent mouse). This mouse has the exact same problem you guys explained above. Tried a bunch of options didn't work. As someone suggested above, opening logitech options s/w solves the issue, but do not want to keep doing it. I raised a ticket with logitech.

Thinking if i should return this mouse!!

3
  • Btw, this only happens if i connect the mouse using Bluetooth and not usb-dongle
    – gangumal
    Jun 1 '20 at 16:57
  • If this is a public ticket could you share so we can all follow along?
    – MrWizard54
    Aug 3 '20 at 18:16
  • 1
    No, i dont think it is a public ticket I will check. if it is a public ticket i will ping the details here.
    – gangumal
    Aug 5 '20 at 20:02
1

The only stable solution that I found is using Scroll Reverser.

https://pilotmoon.com/scrollreverser/

There are no problems using it together with Logi Options.

1
  • This sounds like a good solution, but by now I've already gotten used to it ;)
    – Herman
    Jan 5 at 14:28
1

I haven't tried all of the suggested solutions, but a quick workaround would be to restart your Mac. Also, ensure that the Logi Options app is in the System Preferences -> Security & Privacy -> Input Monitoring

The issue happened when I remove the mouse from Bluetooth, and reconnected.

0

I had a similar problem. Disabling the application specific settings solved the problem for me. I know it's not a real solution, but it might help someone.

0

I found a temporary solution!

As mentioned in 7ynk3r answer, if you kill the "Logi Options Daemon" process it'll start again and everything will be fine. To avoid doing this all the time I installed SleepWatcher. This command-line tools enables you to run scripts on wake and/or on sleep. So you can create a script to kill "Logi Options Daemon" process on every wake.

If you guys want a detailed guide about this, please comment.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .