10

I have downloaded the El Capitan dmg file (InstallMacOSX.dmg) provided by Apple. The expanded dmg image contains the package "InstallMacOSX.pkg" which should be run to create the El Capitan installer but fails with the following message "This version of OS X 10.11 cannot be installed on this computer." presumably because quite reasonably it would not make sense to install on top of a later version of the OS. However in this case I want to create a boot USB drive for an installation on another Mac.

I am stuck in a chicken and egg situation where I need another machine running El Capitan or earlier to create and El Capitan boot installer.

  • For El Cap, there is a tool called createinstallmedia that will make the USB for you – Allan Jan 13 at 7:01
  • Yes I am planning to use this tool but I need to create the "El Capitan" install media first which is where I am having problems. – mhaselup Jan 13 at 7:03
  • I assume you’re double clicking the .dmg file. You have to mount it so you can see the contents. Try this in Terminal hdiutil attach /path/to/dmg – Allan Jan 13 at 7:07
  • 1
    The dmg mounts fine. I can see the "InstallMacOSX.pkg" file but it will not run. Seems the installer is running some logic that says this pkg wants to install a version of the OS that is incompatible i.e. older than what is already on this machine. It would seem like this is jumping the gun is the purpose of the package is to create an installer file, not actually do the installation. – mhaselup Jan 13 at 7:15
  • 2
    Tell you what... You're the newcomer here and I was more interested helping you so I could also learn what the answer was with respect to Catalina than the points (seems more and more I'm sticking with Mojave). I'd rather pass the good karma onto you. If you write up, I'll edit if necessary and up vote so you can at least get some more privileges on this site. – Allan Jan 13 at 10:16
13

Note: This answer was adapted from Klanomath's answer to a sightly different question.

There is a link on the Apple website How to upgrade to OS X El Capitan that will download a file that can be used to create the Install OS X El Capitan application. However, if the model Mac is too new to allow the installation for El Capitan, then message given below will occur when trying to create the Install OS X El Capitan application.

This version of OS X 10.11 cannot be installed on this computer.

If you are trying to create a USB installation flash drive of use on another Mac computer, then you can still use the downloaded file to create this installer. The instructions are given below.

This method was verified by using the following configurations.

  • Catalina on a MacBook Pro 2017 touchbar for use on iMac 2009 24”.
  • Mojave on a Mac mini 2018 for use in a VirtualBox virtual machine on a iMac 2013 21.5".
  • Catalina on a iMac 2013 21.5" for use in a VirtualBox virtual machine on the same Mac.

The following steps can be used to create a USB installer for El Capitan.

  1. Use instructions on the Apple website How to upgrade to OS X El Capitan to download InstallMacOSX.dmg.

  2. Use the Disk Utility to erase a 16 GB or larger flash drive. If the Disk Utility window has a View pulldown menu, make sure Show All Devices is selected. Highlight the flash drive, then click on the Erase button. Use the setting shown in the image below.

    Next, click on the Erase button. When finished erasing, click on the Done button.

  3. Use the Finder applicaition to open InstallMacOSX.dmg.

  4. Enter the commands given below. A folder named El Capitan will be created in the /tmp folder to hold temporary files.

    Note: The easiest way to enter the commands is to copy from this document and paste in the Terminal window.

    rm -rf /tmp/El\ Capitan
    pkgutil --expand /Volumes/Install\ OS\ X/InstallMacOSX.pkg /tmp/El\ Capitan
    diskutil eject Install\ OS\ X
    cd /tmp/El\ Capitan
    hdiutil attach InstallMacOSX.pkg/InstallESD.dmg  -noverify -nobrowse -mountpoint /Volumes/esd
    sudo asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/MyVolume -noprompt -noverify -erase
    

     
    After entering the last command given above, you may get a message similar to the one given below.

    asr: Couldn't personalize volume /Volumes/OS X Base System
    

     
    Some versions of macOS will produce this message while other versions do not. I suspect this is an fatal message because an exit status of 1 was returned.

    Inspection as determined that the part of the command that failed is unimportant.

    Therefore, I was able to ignore this error. However, the error can also be avoided by applying the following steps given in the section below titled Alternative to Using the asr Command.

  5. To finish creating the bootable USB flash drive El Capitan installer, enter the commands given below.
    
    diskutil rename OS\ X\ Base\ System Install\ El\ Capitan
    rm /Volumes/Install\ El\ Capitan/System/Installation/Packages
    cp -rp /Volumes/esd/Packages /Volumes/Install\ El\ Capitan/System/Installation
    cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/Install\ El\ Capitan/
    cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/Install\ El\ Capitan/
    hdiutil detach /Volumes/esd
    sudo bless --folder /Volumes/Install\ El\ Capitan/System/Library/CoreServices --label Install\ El\ Capitan
    cp /Volumes/Install\ El\ Capitan/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/InstallAssistant.icns /Volumes/Install\ El\ Capitan/.VolumeIcon.icns
    cd "$HOME"
    rm -r /tmp/El\ Capitan
    diskutil eject Install\ El\ Capitan
    

     

  6. Remove the flash drive. You are done.

Alternative to Using the asr Command

The command given below may generate a error message and/or hang depending on the version of macOS and perhaps the model Mac you are using.

sudo asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/MyVolume -noprompt -noverify -erase

 

You can avoid entering the above command by following the steps given below.

  1. If the volume on the USB flash drive is no longer labeled MyVolume, then use the Disk Utility to erase the flash drive. Highlight the flash drive, then click on the Erase button. Use the setting shown in the image below.

    Next, click on the Erase button. When finished erasing, click on the Done button.

  2. Enter the following command to create a sparse flash drive image.

    hdiutil create -type SPARSE -size 10g -layout MBRSPUD -fs HFS+J -volname MyImage -attach /tmp/El\ Capitan/MyImage
    

     

  3. Basically, you want to restore to volume MyImage from the hidden file BaseSystem.dmg. The hidden file BaseSystem.dmg is shown in the Finder window image shown below. The drive OS X Install ESD can be found in the hidden volume Volumes in the root folder.

    There are various ways to view hidden files. These ways depend on the version of OS X or macOS you are using. You may have to search the web for a way that works for you.

    Highlight the MyImage volume shown in the Disk Utility main window. Click on the Restore button, then the Image button. Select the BaseSystem.dmg file, as shown below. Next, click on the Restore button.

    After a successful restore, you should see the image shown below. You can click on the Done button and quit the Disk Utility.

    Also, you should get the following popup.

  4. Enter the following commands to clone to the flash drive.

    Note: The dd command takes a long time to complete. See this answer to track the progress of the dd command. The bytes to be transferred is approximately 10 GB.

    getdsk() { local "x=$(diskutil info "$2" | grep Part\ of\ Whole)"; eval $1'="/dev/r${x##* }"'; }
    getdsk DSK1 OS\ X\ Base\ System
    getdsk DSK2 MyVolume
    diskutil unmountdisk $DSK1
    diskutil unmountdisk $DSK2
    sudo dd if=$DSK1 of=$DSK2 bs=1m
    diskutil eject $DSK1
    diskutil unmountdisk $DSK2
    diskutil mountdisk $DSK2
    

     

    Note: Since the original will be immediately ejected and eventually deleted, I did not bother to use the hfs.util command to change the UUID of the clone.

You can now proceed with the rest of the steps.  

References

How do I make a bootable USB flash drive on a Mac?
What is the best way to generate a Yosemite or Mavericks Install USB flash drive?
Install El Capitan with VirtualBox on OS X

| improve this answer | |
  • 1
    I love you! I was searching solution for hours! – Rodrigo Gontijo Jun 20 at 22:54
  • 1
    OMG this is the best answer I have ever seen on any StackExchange site! I am very experienced with MacOS and Linux but I didn't know about the asr command :) Thanks for taking the time to write this comprehensive article! – randomcontrol Jun 24 at 22:23
  • @david i am stuck at Copying installer files to disk... waited 4 hours. Any soluttion ? – Jack Jun 28 at 2:11
  • Since you posted the same comment to the answer provided by @ChrisBraucker, could you specify which step in my answer were you are having this problem? – David Anderson Jun 28 at 17:48
8

I was stuck in this very same situation for a while now and have found a way to create an install media (installing while we speak) on MacOS Catalina. A bit of Terminal magic is required, but nothing too fancy.

I will create a temporary folder on the Desktop so it is easier to inspect the structure with finder.

Steps to take to get the command running as suggested in https://support.apple.com/en-sg/HT201372

  1. Download and mount the image for El Capitan (e.g. double click onto the .dmg file)
  2. Open the Terminal app
  3. (optional) Change to the Desktop cd ~/Desktop
  4. (optional) Create a temporary folder mkdir installCapitan && cd installCapitan
  5. Extract the installer here xar -xf /Volumes/Install\ OS\ X/InstallMacOSX.pkg
  6. Change into the resulting folder, with cd InstallMacOSX.pkg
  7. Now you're greeted with several files, e.g. Payload, Scripts, InstallESD.dmg
  8. Unpack Payload with tar xvzf Payload
  9. Now you have the Install OS X El Capitan.app Apple talks about in the link above
  10. One more step, move the install data to where it should be: mv InstallESD.dmg Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/

Now running the createinstallmedia command should work when given the right paths, and this should work:

sudo Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia \
        --applicationpath ./Install\ OS\ X\ El\ Capitan.app \
        --volume /Volumes/my_install_volume

Change your installation volume path accordingly and be careful to pick the right one, otherwise loss of data may occur.

edit: If your installer fails with something about not being able to verify the install media, check this answer out, it helped me: https://apple.stackexchange.com/a/232016/371520

Good luck

| improve this answer | |
  • 2
    I arrived here after hours of messing about trying to create an installer for an old iMac on. a new Mac, what an absolute pain. This guide worked for me but please see domc's note below about the extra step needed after step 5 – Dorian Farrimond May 25 at 16:32
  • @domc I incorporated the information, thank you for pointing this out! – ChrisBraucker May 26 at 19:36
  • @ChrisBraucker i am stuck at Copying installer files to disk... waited 4 hours. Any soluttion ? – Jack Jun 28 at 2:11
  • @Jack sorry for the late reply, did you have any success after all, or did you try restarting the installer, especially with sudo? long running time could always be related to slow disk performance (usb interface or storage medium). if that's the case you can check this in the terminal with iostat -w 1 – ChrisBraucker Jul 9 at 11:10
  • @ChrisBraucker thanks dude. i have success with new pendrive but now i am stuck while installing on mac mini. i also raised question here apple.stackexchange.com/questions/394919/… – Jack Jul 9 at 16:50
3

The answer is that there appears to be a problem with Catalina creating an installation app for other versions of OSX-certainly with El Capitan from the issue here. Solution was to follow the Apple supplied procedure https://support.apple.com/en-sg/HT201372 but on another version of OSX-Sierra worked in this case.

| improve this answer | |
  • I agree using another version of OS X is a workaround, but if you don't have any other Mac available (I have 2 other Macs at home, both of them with Catalina and so useless) this is a problem and an open question yet. Has anyone found another solution? – Jorge Ramírez Apr 5 at 21:15
2

I don't have enough reputation points to vote or comment on Chris Braucker solution, but seems to be working for me.... writing to USB stick as we speak after multiple hours of trying to find way of getting Catalina to create bootable USB drive for El Capitan.

One extra step (5b) might be added for relatively unsophisticated terminal users, that took me a while to figure out. After Step 5, you're not presented with the folder with payload in it. You first have to do cd InstallMacOSX.pkg to get inside this folder and see the payload file

| improve this answer | |
  • Welcome to Ask Different! Please refrain from adding comments in the Answer section, this is for answers to the questions. Once you have sufficient reputation you’ll be able to add comments and ask follow-up questions. To gain reputation, answer questions that are clear and concise. - From Review – fsb Apr 19 at 12:32
  • 1
    It’s best to edit an existing answer to explain your setup and addition. Answers need to stand alone to avoid down votes and possible deletion. Do you feel comfortable making this an edit on the existing answer to improve it? – bmike Apr 19 at 12:39
  • 1
    Agreed it's better that this would be a comment / edit rather than separate answer, but I was restricted from doing that. However, I do consider my comment provided useful information to someone else, that might help them get an answer that worked, so on balance I considered it better to post something somewhere, than not add something that might help others with tricky problem – domc Apr 20 at 7:09
0

I presume that you want to create a bootable El-Capitan USB installer? Maybe can check this guide from Apple?

https://support.apple.com/en-sg/HT201372

| improve this answer | |
  • Yes, I reviewed this document. Unfortunately when you get to the bit "OS X El Capitan downloads as a disk image that contains a file named InstallMacOSX.pkg. Open this file and follow the onscreen instructions. It installs an app named Install OS X El Capitan into your Applications folder." it is not possible to install the package and the error "This version of OS X 10.11 cannot be installed on this computer." is displayed. – mhaselup Jan 13 at 6:58
  • The meaning by "installs an app name install OS X El Capitan" is not by double clicking, but rather move the whole file into Application folder. If you do not want to move the file to the Application folder, and keep it in your "Download" folder, you need to make some adjustment to the sudo instruction described in the document above... – Yudi Setiawan Jan 14 at 5:25
  • Modified command if the OS X El Capitan installation is NOT MOVED to Application Folder: sudo ~/Downloads/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume --applicationpath ~/Downloads/Install\ OS\ X\ El\ Capitan.app .....Please change the "MyVolume" to correct name of your USB drive – Yudi Setiawan Jan 14 at 5:29
  • Thanks for the clarification on the location of the El Capitan installation file. In my case I was expecting it to be created in the "Application" directory by installing the package (which I ultimately did successfully on another Mac) so I could then run the "createinstallmedia" command. The issue which I was trying to resolve was the fact that I couldn't install the package in the first case so the expected location of the installation file was a moot point. – mhaselup Jan 14 at 7:34
  • Maybe you are right. Good that you can finally create it. – Yudi Setiawan Jan 15 at 7:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .