1

How can all formatting be removed from a sheet in Numbers so each cell only contains the text, with links no longer clickable?

2
  • have you tried exporting to CSV and then importing it right back in? CSV is text only – Steve Chambers Jan 11 '20 at 0:54
  • The exported CSV is correctly formatted. This is about using Numbers with some enhancements disabled. – ponies Jan 14 '20 at 17:57
1

If you just want to remove hyperlinks, this post (the first result of this Google search) should help. Summarized below:

  1. Select all cells using +A (or Edit -> Select All)
  2. Copy cells using +C ( or Edit -> Copy)
  3. Paste and Match Style using +++V (or Edit -> Paste and Match Style)

This will remove all hyperlinks, however it will keep formatting like Bold, Italics, etc. If you want all formatting to be gone, use the suggestion from Steve Chambers to export to CSV and import from CSV, as the CSV Format is just plain text and doesn't save any formatting.

  1. File -> Export to -> CSV...
  2. Select the CSV you just exported in Finder and right click -> Open With -> Numbers

This will completely open a new Numbers document without formatting, unless you have Numbers set to automatically detect hyperlinks. If you do not want hyperlinks to be detected:

  1. Open Numbers preferences using +, (or Numbers -> Preferences...)
  2. Go to the Auto-Correction tab and uncheck "Automatically detect links" under the Formatting section
3
  • I've got the Autodetect link off, but it still converts them, and adds header styling, on import from CSV. It may be that email addresses are treated differently than URLs. Could a blank template be set as the default? – ponies Jan 14 '20 at 17:54
  • The link removal process does work. – ponies Jan 14 '20 at 18:01
  • The CSV option will remove the formulas, if any, in addition to formatting. – Alper Feb 10 '20 at 13:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .