1

I encounter some problems with my MBP late 2016.

  • I thought it was from SSD, I have ejected it (now running on external one)
  • I thought it was from RAM, I have run memtest86, the result was OK
  • I have reset the NVRAM and SMC

The last thing I’ve tried is running

sudo pmset -a standby 0

But in the very short time I’ve used the laptop, I cannot say it worked.

Update 11.01: It does not work. Crashed in the middle of the night, while in sleeping mode.

  • Tried now to run again Apple Diagnostics (before ejecting SSD, it does not return any error).
    Now it says:

There may be an issue with a storage device
Reference Code: VDH002

A friend of mine that works in the electronics area said that the problem is related 100% to CPU. Can this be the real problem?

Kernel panic log:

Anonymous UUID:       7C99A374-6082-162E-9E48-E9EF518D47B5

Fri Jan 10 12:16:55 2020

*** Panic Report ***
panic(cpu 2 caller 0xffffff80182bc42f):  initproc exited -- exit reason namespace 2 subcode 0xa description: none

uuid info:
 0x116a20000    uuid = <dfc3c4af-6f97-3b34-b18d-7dcb23f2a83a>
 0x10bc46000    uuid = <bbd445b6-fba9-3a9c-828f-a112f63e2080>

Thread 1 crashed

RAX: 0x0000000000000000, RBX: 0x000000010bc94068, RCX: 0x000000010bc91000, RDX: 0x000000010bc94088
RSP: 0x0000700001c4d3f0, RBP: 0x0000700001c4d490, RSI: 0x000000010bc94078, RDI: 0x000000010bc46000
R8:  0x000000010bc46ae8, R9:  0x0000000000000d0e, R10: 0x0000000000000010, R11: 0x0000000000000202
R12: 0x0000000100021c1f, R13: 0x0000000000001eb0, R14: 0x000000010bc96748, R15: 0x000000010bc46000
RFL: 0x0000000000010246, RIP: 0x00007fff5f8cfb7f, CS:  0x000000000000002b, SS:  0x0000000000000023

Thread 0: 0xffffff802c565520
    0x00007fff5fa0a126
    0x00007fff5f893ede
    0x0000000000000000

Thread 1: 0xffffff802d7b8a40
    0x00007fff5f8cfb7f
    0x00007fff5f8cfa07
    0x00007fff5f8cf8d1
    0x00007fff5f92cb2a
    0x000000010bc67c1f
    0x000000010bc78439
    0x00007fff5f88463d
    0x00007fff5f886de6
    0x00007fff5f895f42
    0x00007fff5f88a792
    0x00007fff5f88b396
    0x00007fff5f8936ed
    0x00007fff5fac4611
    0x00007fff5fac43fd
    0x00007ff991871e00

Thread 2: 0xffffff8034ae9520
    0x00007fff5fac43f0

Thread 3: 0xffffff802fa20a40
    0x0000000000000000


Mac OS version:
18G103

Kernel version:
Darwin Kernel Version 18.7.0: Tue Aug 20 16:57:14 PDT 2019; root:xnu-4903.271.2~2/RELEASE_X86_64
Kernel UUID: C41337A1-0EC3-3896-A954-A1F85E849D53
System model name: MacBookPro13,1 (Mac-473D31EABEB93F9B)

EOF
Model: MacBookPro13,1, BootROM 241.0.0.0.0, 2 processors, Intel Core i5, 2 GHz, 8 GB, SMC 2.36f98
Graphics: kHW_IntelIrisGraphics540Item, Intel Iris Graphics 540, spdisplays_builtin
Memory Module: BANK 0/DIMM0, 4 GB, LPDDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424A544D4C41522D4E5544
Memory Module: BANK 1/DIMM0, 4 GB, LPDDR3, 1867 MHz, 0x80AD, 0x483943434E4E4E424A544D4C41522D4E5544
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x159), Broadcom BCM43xx 1.0 (7.77.61.2 AirPortDriverBrcmNIC-1305.8)
Bluetooth: Version 6.0.14d3, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: USB2.1 Hub
USB Device: USB3.1 Hub
USB Device: AS2115
Thunderbolt Bus: MacBook Pro, Apple Inc., 41.1

Update 12.01: I have ejected the internal and external SSD, did an SMC and NVRAM reset, but still, receive the error.

Update 2 12.01: Tested RAM with memtest86 and passed without problems

Update 3 12.01: get an eraser and cleaned the contacts of the SSD. After that, I have mounted it to the laptop and installed Catalina from an external SSD system installer and worked smoothly. Disk Utility says that's healthy.

  • It could be a 3rd party kext, but the panic report looks to have been truncated. First test is always to uninstall any 3rd party apps with loaded kexts at panic – Tetsujin Jan 10 at 14:10
  • @Tetsujin it's a fresh install and it's the full report I get from the system, nothing truncated by me. Thanks! – Silviu Jan 10 at 14:23
  • I have added some updates. I have ejected the SSDs and still receive VDH002 error regarding storage. – Silviu Jan 12 at 10:47
1

The screenshot with the panic shows that the reason for the kernel panic was that launchd stopped running.

I would suggest looking at the log files for launchd to see if you can find the reason for that in there. Usually you'll see something like "exited at instruction [...]" or "trying to read/write [...]" or "[...] (sent by PID [...])" right before the crash.

I don't see anything in your observations that indicate that this must be a problem with the CPU. It could be a software problem (such as problem with your installation media) - and it could be a hardware problem (most likely I would say is RAM - might also be a cooling problem).

I would suggest booting into Internet Recovery and let the machine sit there for an extended period of time to see if it crashes here. If it still crashes there, I would swap the RAM modules and check if that fixes the problem.

  • There are no installation media. It was installed via internet recovery. RAM is ok, I tested it with memtest86. Regarding logs, I cannot find anything related to your hints. But still, I don't understand why I receive that error from the screenshot if I have no SSD inside. If it'is a cooling problem, shouldn't diagnose to report it instead of reporting a storage problem? – Silviu Jan 12 at 16:11
  • memtest86 doesn't necessarily mean that the RAM is OK - it can be OK for a while, and then go bad when the machine gets warmer, etc. Have you tried letting it sit in Internet Recovery Mode as I suggested? ... The screenshot is so unclear that I cannot read the storage error code you have, so it's hard to tell what it it could be. – jksoegaard Jan 12 at 19:10
0

Unfortunately, I can't comment, so here is my advice: I would suggest not only to boot into internet recovery mode, but especially into safe mode/single user mode. You can check the available startup options here.

Also, before you proceed with anything: Save your data either in a backup or just copy the files somewhere.

If you are unable to resolve this issue by yourself, try to go to an apple store/certified repair shop. They should be able to help you out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .