2

MacBook Air 11' mid-2011.

When opening Xcode from Terminal, I get this:

Kukoda-MacBook-Air:~ kukodajanos$ sudo open /Applications/Xcode.app 
Password:
LSOpenURLsWithRole() failed with error -10810 for the file /Applications/Xcode.app.

Do I need 10.0?


enter image description here

Following this thread: https://forums.developer.apple.com/thread/115847


Using Xcode.app/Contents/MacOS/Xcode executable:

Last login: Fri Jan 10 10:20:11 on ttys001
Kukoda-MacBook-Air:~ kukodajanos$ /Applications/Xcode.app/Contents/MacOS/Xcode ; exit;
dyld: Library not loaded: @rpath/XcodeKit.framework/Versions/A/XcodeKit
  Referenced from: /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/Versions/A/IDEFoundation
  Reason: image not found
Abort trap: 6
logout
Saving session...
...saving history...truncating history files...
...completed.
Deleting expired sessions...1 completed.

[Folyamat befejeződött]
4
  • macOS High Sierra 10.13.6 is the minimum version of macOS required to run Xcode 10.1. Make sure you have the said versions of macOS and Xcode installed on your Mac.
    – Nimesh Neema
    Jan 10, 2020 at 9:29
  • I am sure I have
    – János
    Jan 10, 2020 at 9:35
  • @János it can be code sign issue, try the executable in show package contents under Macos folder.
    – anki
    Jan 10, 2020 at 9:38
  • Hi it says IDEFoundation.framework not found see more above
    – János
    Jan 10, 2020 at 9:43

0

Browse other questions tagged .