0

Edit: OK, the weirdness factor for me has gone off the charts. Now, everything works in all situations I described below 10 mins later.

I tried everything I did below several times, you know, measure three times cut one and all that jazz.

I have three witness who saw the issue and agreed there's something up here.

Unless somehow three people have misconstrued events in the worst possible way, which is possible but improbable, then there must have been some kind of strange electrical anomaly.

Well, ohm my - short of an electrical fault in the building, I'm at a loss.

Still, if anybody has a clue why this might happen, please enlighten me.


Location: UK (so UK plug sockets)

A really odd problem I'm trying to figure out, the complete lack of sense it makes is doing my electrically-uninformed head in.

OK, so in our office, we've got a whole bunch of Macs. I use an iMac.

My colleague has a MacBook Air.

If I plug the charger for the MacBook air directly into the wall socket, it works fine.

However, if I then plug the same charger into a socket in a typical domestic 4-gang extension lead, it doesn't charge - with NOTHING else plugged into the wall outlet, or the 4-gang extension.

If I plug my monitor, or iMac into the same socket on the same extension cable plugged into the same wall socket, it works fine.

MacBook Air charge, negatory. Same socket, same extension, same wall socket.

Thinking there was something weird about the 4-gang extension cable, I found another more industrial looking reel-wound extension cable, again with four sockets. Same problem. Again, both my iMac and monitor work when in the same socket of the same extension cable, in the same wall outlet.

By this point, one could safely assume that the charger itself is a dud. Unfortunately, life is not so simple.

If I go across the room to where another colleague has their MacBook Pro working just fine and dandy, and plug in the same MacBook Air charger into the known-good socket in my other colleagues extension (his charger was not plugged directly into a wall-socket, but a 6-gang extension with every other plug socket in use), it all works just fine - as expected, no surprise there. In an extension cable, not the wall socket!

Further, I found another two MagSafe 2 chargers that also work in my other colleagues extension, and then plug them into one of the two extensions leads that I previous has zero luck with, the same problem occurs. No luck. Nada.

I've repeated the process with the other 2 MagSafe chargers, and I get the same problem.

They just don't work when plugged into some extension cables, but all work just fine when plugged into the same wall-socket the extensions were plugged into, or my other colleagues extension.

Again, my iMac (and my phone charger, and my monitor) does indeed work in the same socket of the same extension cable plugged into the same wall-socket.

I'm really confused about what is causing this, it seems clear that there's some difference in how the two extensions I've tried (and failed with) work, and my other colleagues extension, in which the MagSafe charger does work.

Surely there can't be two types of UK extension? There's only one type of wall-socket, as far as I know!

It is also clear that the iMac is not subject to the same problem, because that works fine in literally all sockets mentioned above.

If anybody knows why this is happening, I would absolutely love an explanation. I cannot accept this as a reality until I know why this happens! :-p

I've tried Googling, but if you even hint at "MacBook charger not working", you are absolutely inundated with irrelevant results.

Cheers

8
  • Obviously, the charger and extension cable work - I am guessing that the cable you have has some sort of protection against ungrounded devices which the Magsafe charger isn't. See this answer for more details on this: apple.stackexchange.com/a/10563/119271
    – Allan
    Jan 8 '20 at 17:32
  • Is there any model info for your extension cable?
    – Allan
    Jan 8 '20 at 17:33
  • Are you using the "extra length" of cable from the power brick, or do you have the plug directly on the brick? The latter is not earthed correctly. Socket splitters often have extra circuit breakers built in.
    – benwiggy
    Jan 8 '20 at 17:47
  • Grab a mains tester from B&Q (max a tenner) & make certain there’s no polarity issue.
    – Tetsujin
    Jan 8 '20 at 18:41
  • @Allan, one of the extension leads I tried is a generic cheap thing with a fuse in it, and no other information. The other one is an old Homebase brand reel-wound 50m extension, it says it has a thermal cut out with a little red button to reset it after letting it cool down, but no other information. So perhaps as benwiggy said above, they both do have circuit breakers built in but don't say so and there was some fault somewhere along the line.
    – thephpdev
    Jan 9 '20 at 9:46

You must log in to answer this question.

Browse other questions tagged .