Brand new 16" MacBook Pro with a highly frustrating issue. Only one potential fix but only works temporarily. Any help is much appreciated.

- Details I just received a 16" MBP today, and set it up from Migration Assistant as I've done with many Macs successfully over the years. However, it wouldn't connect to WiFi, stating, "Wi-Fi has the self-assigned IP address 169.254.*. and will not be able to connect to the Internet.

This was when I was connecting to previous known networks. However, it WAS able to connect to one open SSID which I'd never used before successfully.

The only fix that has mysteriously worked is to change the MAC address. When I run the command line on this forum post, the WiFi successfully connects. However, upon restart, it once again reverts to self-assigned IP. (I believe Catalina doesn't allow MAC address changes).

Can anyone please help explain how I can resolve this, why the MAC address change works temporarily, and how I can ensure a more permanent solution? It's a custom ordered 16" MBP that took 5 weeks for delivery, so I'd highly prefer not to send it back.

Here are a list of things I've tried:

  1. Resetting SMC/NVRAM/PRAM
  2. Renew DHCP Lease
  3. Remove/delete network
  4. Delete plist/prefs in the SystemConfiguration
  5. Tried two different hotspots
  6. Tried two physically diff networks at home and work
  • Sorry, do you have any recommendations for how I may do that? (what I can assign) – IslandMac Jan 7 '20 at 13:54
  • I wasn't able to connect once I did that. – IslandMac Jan 7 '20 at 14:18
  • I mean there are about 20 devices connected currently. But I also had this issue at work on a diff physical network, and via two diff hotspots via a diff ISP. I did as you noted and just changed the IP address manually and the router. – IslandMac Jan 7 '20 at 14:28

I see two possible problems here:

First possibility is that your MAC address after reboot is somehow invalid (i.e. for example set to all zeros). That could make your DHCP server (probably in your home router) reject your request for an IP address).

Check if that is the case by running the following command in the Terminal:

ifconfig en0

Note the line that starts with "ether" - it should have a valid MAC address looking something like f2:23:48:a3:1e:22 or similar.

Second possibility is that the problem is really with your WIFi router / DHCP server and not locally with your laptop. This could happen if your router added the new MacBook Pro's MAC address to a block list or similar.

Check the router's settings and management interface to ensure that the MAC address of your new MacBook Pro is not listed in any black lists - and if you have white listed your old computer, then white list your new computer as well.

  • Thanks for that. I checked as you noted, and the MAC address is f8:ff:c5:69:88:8e. In terms of the router - would that be the case on two diff physical networks (diff ISP as well) and two diff mobile hotspots? – IslandMac Jan 7 '20 at 13:10
  • Try setting your MAC address to: f8:ff:c5:69:88:8f. Does that work? – jksoegaard Jan 7 '20 at 13:15
  • I actually don't know how to do that. And is it correct that Catalina will just revert upon start up? – IslandMac Jan 7 '20 at 13:16
  • You wrote in your question that you set the MAC address after start up to some random value, and then it works? - If yes, just set it to the value I have given instead of a random value. – jksoegaard Jan 7 '20 at 13:17
  • Well, ANY version of macOS will revert after startup. It doesn't have anything to do with Catalina. – jksoegaard Jan 7 '20 at 13:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .