0

I want the @ symbol to be on the "Q" key.

I need to switch between Linux and Mac daily. I don't want to think about which keyboard is under my fingers.

My ThinkPad keyboard is connected via USB to the MacBook. It works fine, except that the @ symbol is at the "L" key and not on the "Q".

I could not find a way to change the configuration of the Mac to match my needs.

How to solve this?

trackpoint-i-love-it

3
  • There’s also lots of info missing and/or not complete. Like you “ThinkPad keyboard.” ThinkPad is their brand of laptops and I am not familiar with laptop specific USB keyboards or are you referring to the actual ThinkPad keyboard from the laptop? Also, which a Mac? What version of macOS? This doesn’t sound like a US keyboard, so which keyboard layout are you using?
    – Allan
    Jan 6 '20 at 10:39
  • @Allan I added a picture. I hope this is more clear now. If not, please tell me what you are missing. Thank you.
    – guettli
    Jan 7 '20 at 10:43
  • Is your input source set to German Standard (and not German)? What version of MacOS (Apple > About this Mac)?? Jan 7 '20 at 12:42
1

Go to System Preferences > Keyboard > Input Sources and make sure this is set to "German Standard" and not "German".

If this does not do the trick, or if you do not have the choice of German Standard, then it is pretty easy to make a custom layout to put this character anywhere you like with the app Ukelele.

1
  • I need to upgrade to MacOS Catalina first. Now "German Standard" is available and works. Thank you very much!
    – guettli
    Jan 9 '20 at 9:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .