0

I started my mac today at work and I got a message saying the mac could not recognize my keyboard. I then had to do a short wizard by typing the key next to shift.

When I then tried to use the standard < key on my nordic extended mac keyboard, ' gets emitted. It seems like the two has switched places.

How can I make the keyboard behave as it is intended to?

This is the keyboard I have: Norwegian mac keyboard w/ numpad

You can see this in the gif below; It starts out as how I want it to be, but if i press any key, the keyboard image in the settings page switch over to the strange layout.

Image from Gyazo

  • What does the key under ESC produce? – Tom Gewecke Jan 6 at 13:12
  • 1
    It looks like the machine thinks the keyboard is the wrong "type". See this note m10lmac.blogspot.com/2009/12/fixing-keyboard-type-problems.html – Tom Gewecke Jan 6 at 13:14
  • Sorry for late reply, I have had a cold. The key under ESC now proudces <. The two keys have just flipped haha. – Sølve Tornøe Jan 8 at 11:17
  • Nice article! I will test it at work tomorrow 💯 Thanks! – Sølve Tornøe Jan 8 at 11:18
  • I tried all the tips in the article, none helped :/ When I do the Keyboard setup assistant, when I press the key next to shift, it nags saying "Press the key next to shift" – Sølve Tornøe Jan 9 at 6:51
0

I found this article suggesting me to delete a file

running the following command, then doing a reboot followed by running the assistant again fixed the issue!

sudo rm /Library/Preferences/com.apple.keyboardtype.plist

This was also mentioned in the article @Tom Gewecke commented above, but I overlooked it when I did not find the mentioned file in finder. I suppose it might be a hidden file or something.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .