1

The HDD is a brand new MyPassport WD 4Tb. I recently used it as my main backup and before I had the time to reformat another drive for a second backup (which means that some data on that drive are crucial to recover), this new HD stopped mounting on my MacBook Pro Mojave where it was always attached to (I don't know what happened).

I tried DiskUtility which failed. I tried fsck_hfs in Recovery or Single User Mode on 2 different Apple computer as well as on Linux Mint... all failed. The returned error is Invalid Key Length and Catalog File not found for extent.

I tried Stellar Data Recovery which ran for a full day and now it is stuck at the beginning of the yellow phase 3 of 4. It has not crashed, no error message is displayed. I tried their new Sellar Volume Repair which failed. I tried iBoySoft Data Recovery which crashes everytime I do a deep scan.

I do not understand why such disk failure is so difficult to repair! What can I do? Advice will be deeply appreciated.

2
  • 1
    Is the WD MyPassport an archive or a backup (Time Machine?)? Best bet is Alsoft's Disk Warrior...
    – klanomath
    Commented Jan 5, 2020 at 12:10
  • A definite thumbs up for Disk Warrior on HFS drives.
    – Tetsujin
    Commented Jan 5, 2020 at 12:18

0

You must log in to answer this question.

Browse other questions tagged .