3

I have a 2018 13" MacBook Pro with Touch Bar and Four Thunderbolt 3 Ports, and I wanted to know where I lie with Ubuntu (or another distro) for dual booting.

I have successfully booted Ubuntu onto my Mac, from a USB drive and it works with an external keyboard and mouse, but that's not perfect and I'd like it fully working if possible.

I have come across this and it looks promising, however my Mac is a 15,1 and I can only find a 15,2 there. Strangely, there are two 15,2 MacBook Pros - 15" 2018 and 15" 2019. Mine, of course, is neither. I’m basically a little unsure how the marketing / model year numbers are supported for Ubuntu.

Is there an easy to install (i.e. well documented) distribution of Ubuntu that works on a 2018 MacBook Pro?

3

This is something that must be extrapolated as the 2015 through 2017 MacBook Pro's aren't vastly different than the 2018-2019 MacBook Pros. The key functions:

* Audio                   → Not Working
* Suspend & Hibernation   → Partially Working
* TouchBar                → Partially Working
* TouchID                 → Not Working
* WiFi                    → Working on 13,2; 13,3; 14,2; 14,3

These will follow with the same statuses as MacBook Pro models 13,2 through 14,3 as noted.

Now, one very safe bet is to go for the main LTS build of Ubuntu as it is exceptionally well documented and has several dedicated support sites as well as this Q&A site.

Now, it's entirely possible that nothing works because of the new T2 chip that encrypts and controls the storage meaning you have to disable all boot security unless Apple signs your OS. Given that, running Ubuntu on a 2018 and beyond MacBook Pro computer will be limited to virtualization - VirtualBox, Parallels, VMWare, etc. (IMO) this is a better path to pursue.

You can disable external boot and run externally, but the T2 SSD aren’t available for any OS other than Windows or macOS in 2020 due to secure boot and lack of drivers for the T2.

|improve this answer|||||
2

If you don't want to use extra keyboard and mouse drivers you need at least version 5.3 of the Linux kernel (the current stable version is 5.4.8). As mentioned in your link to State of Linux on the MacBook Pro 2016 & 2017

Keyboard & Touchpad

Works out of the box with Linux 5.3 and above.

For earlier Linux versions you can get the driver from https://github.com/roadrunner2/macbook12-spi-driver.

This would therefore be Ubuntu 19.10 (Eoan Ermine) which was released in October 2019. The current LTS will not work as it has Kernel version 5.0.

Ubuntu 18.04.3 ships with a v5.0 based Linux kernel updated from the v4.18 based kernel in 18.04.2.

If you want a LTS release then according to Ubuntu documentation you need to wait. This kernel will be included in the LTS release 18.04.4 scheduled for February 2020.

Keep an eye on the Arch Wiki and State of Linux on the MacBook Pro 2016 & 2017 for more up-to date info but in general as recent Macs are poorly supported LTS is not a good choice. As the link says:

To state the obvious: The newer the kernel the better. The information below assumes that you run Linux 4.13 or newer. If in doubt which kernel to use, the latest significant improvements are part of Linux 5.3.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .