2

This question has been asked on here many times before but I cannot find a solution that actually works.

Macbook Pro: 2015
MacOS 10.14.6
External Hard Drive: Seagate 4TB (2 TB partitions) (No external power supply)

Sometimes I can just unplug the external hard drive and plug it back in and it is magically recognized again.

But sometimes the magic does not work and I have to reboot. This is incredibly annoying as I have 12 desktops running with a variety of programs and it takes a lot of work to set this up again after a reboot.

Having to constantly reboot my mac book pro every time that macos fails to mount the external hard drive is very annoying.

When I run "sudo diskutil list", I should see 2 TB partitions on my external hard drive. I do not.

>diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         1.0 TB     disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1.0 TB     disk1
                                 Physical Store disk0s2
   1:                APFS Volume d                       600.4 GB   disk1s1
   2:                APFS Volume Preboot                 43.9 MB    disk1s2
   3:                APFS Volume Recovery                510.4 MB   disk1s3
   4:                APFS Volume VM                      4.3 GB     disk1s4

I expect to see something like this:

>diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:          Apple_CoreStorage Macintosh HD            999.7 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (internal, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS d                      +999.3 GB   disk1
                                 Logical Volume on disk0s2
                                 8A8B74D4-BB0A-4593-8F8C-068383425497
                                 Unencrypted
/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *2.0 TB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Backup                  2.0 TB     disk3s2
/dev/disk4 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk4
   1:                        EFI EFI                     209.7 MB   disk4s1
   2:                  Apple_HFS seagate_4tb             2.0 TB     disk4s2
   3:                  Apple_HFS Untitled                2.0 TB     disk4s3

As suggested in Sometimes Mac doesn't recognise my external hard drive, I tried using the console app. enter image description here

When I connect the external drive to the USB slot I see a lot of messages in the console. I initially thought this meant that the os was detecting the device because I saw the IOUSBHostDevice in the message. However, on closer inspection, this seems to be Bluetooth.

If there is a way to determine from console what I should do to persuade the os to actually recognize the device and mount the volumes, I am not seeing it.

I did find one suggestion for restarting the USB subsystem which involves:
1: Installing Prober.app 2: Running a command like this:

USB\ Prober.app/Contents/Resources/reenumerate -v 0x00000bda,0x00008153

I have no idea what that hex string represents but this feels a little dangerous and unnecessarily complicated to fix a problem that occurs so frequently.

Surely there is a safer and simpler way to communicate to macos that it needs to detect the external hard drive?

6
  • 1
    How did you identify the lines from the log? the internal bluetooth connection is run through the usb connection. You seem to have found the bluetooth status. – historystamp Jan 4 '20 at 21:21
  • @historystamp: my bad. Thanks for pointing out this error. – Alex Ryan Jan 4 '20 at 22:07
  • This can help with i/o problems. thenextweb.com/lifehacks/2017/06/14/… – historystamp Jan 5 '20 at 0:03
  • You need to ignore the link provided by @historystamp - it's patently wrong. As for watching console, as I wrote in the answer you linked to, you need to be watching the Console while simultaneously plugging in the drive. If you don't see it appear in Console, it's not being recognized meaning it will never mount no matter what you do. – Allan Mar 3 '20 at 4:12
  • I suggested resetting the SMC. A common suggesting when encounter strange I/O issues. Worked for me two times that I remember over the years. – historystamp Mar 7 '20 at 21:42
-1

Try to connect your HDD to WINDOWS, then remove all hidden folders and trash from your HDD and check the drive for life system errors.

enter image description here

Good luck!

4
  • So many questions..why must you use Windows (especially in an Apple centric site)? How does deleting hidden files and trash address the issue and finally, what's a "life system error" and how would you check for them? – Allan Mar 3 '20 at 4:33
  • @Allan Because I spent whole day to find a solution. This only works for me. I have attached a screenshot to show what is "life system error". – Dmitry Grinko Mar 3 '20 at 4:41
  • Also, I would like to add that HDD should have an ExFAT format. – Dmitry Grinko Mar 3 '20 at 4:43
  • It's probably a good idea to take a look at the How to Answer post in our Help Center. The answer, as written feels very disconnected from the original question. – Allan Mar 3 '20 at 4:47
-1

There is a 3rd party app I use for things like this called Mountain which gives you control over all your drives. It's not free but has a free trail so you can check if it works. It's available from the link above.

1
  • why the downvote? – Natsfan Mar 3 '20 at 14:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .