0

I was trying to solve an issue with memory disappearing to 0kb, and after reading some post here I have :

  • delete some files from cache folder(library)straight to rubbish bin

  • An deleted some core files applying this in the terminal:

    cd /cores; sudo find . -mtime +30 -type f -delete
    

I've stopped bot process as something was not right (some items where changing the logo as programs for example) MyMac has restarted to the folder with interrogation. I ve tried to find solution but nothing. Neither command+r neither alt key where working. alt(option) just show a mouse in the screen.

If there is something I can do ? Still don’t understand why it happened as I understand here it was safe to do it. Is there a solution not loosing the info?

9
  • I'm not really sure what happened, but the command you ran is not really safe. If the cd command fails, it will go ahead and delete files wherever you are instead of inside the /cores directory. It's possible the second command deleted a bunch of files somewhere else, and depending on where that was it may have done a lot of damage. Do you have a backup of your Mac? How important was the data on it? Jan 4, 2020 at 5:17
  • I think this has happened. I thought to read here was safe doing it. Thanks for the update Gordon. I might be lucky and have a back up from last year if I remember well..anyhow I tried to connect the hard drive pressing ALT but just a mouse appears. Data to be honest programs and plugins where important as my other hardrive it has dissapear with all my library’s and plugins. Not good beginning for 2020. What you can suggest me? I wish to be more computer friendly. Thanks again. At moment only I can access to the folder interrogation or the mouse pressing ALT as Command R doesn’t work
    – J. Who
    Jan 4, 2020 at 5:31
  • Do you mean a question mark like in the image here? If so, that means that the Mac cannot find an operating system to start up, which means something really critical got deleted. If you want to try to recover data from the Mac, you'll probably need more help than we can give over the Internet. If not, you might be able to reinstall macOS using Recovery mode. Jan 4, 2020 at 6:34
  • Exactly Gordon, that’s the image. None of the options are working so I can’t proceed with it,(recovery mode) I do have a backup so I don’t know if will be able to reinstall anyhow.
    – J. Who
    Jan 4, 2020 at 14:47
  • Is there a model year of the mac or do you just need help finding the generic article on how to do an erase install of MacOS from Apple’s support site?
    – bmike
    Jan 4, 2020 at 15:30

0

You must log in to answer this question.

Browse other questions tagged .