3

Reinstalled 10.15, signed into icloud, had previous 10.13 on another partition for a while.

10.15 is a clean install. The apps that provide those services haven't even been installed. enter image description here

~/Library/Services is empty. Tried grepping the whole filesystem for those. No match.

The only place they seem to exist is in defaults manager. So I tried removing ~/Library/Preferences/com.apple.ServicesMenu.Services.plist and ~/Library/Preferences/pbs.plist. Didn't help.

Why are those services in that menu on a clean installation and how to I get rid of them?

  • Can you right click and remove ? – ankii Jan 4 at 8:31
  • best you ever get is 'show in Finder' - which invariably goes to the Applications folder not the Service location – Tetsujin Jan 4 at 10:47
1

Well, I'll be damned.

enter image description here

In the evening I removed 10.13 partition. Immediately after the list remained the same. In the morning the list was fixed.

I believe what happened is, this list is constructed by scanning all available mountpoints. it went into the old volume and picked up the old service files. It probably runs an update every few hours.

This is such a weird behavior.

| improve this answer | |
  • 1
    Some Library components, like Services, QuickLook and Spotlight plug-ins, exist inside the Application's bundle, and are picked up by the OS. If the app is available, then the Services will appear. – benwiggy Jan 4 at 15:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .