2

I'm setting up a new MacBook. On my previous MacBook, I had two reference sources ticked in the Dictionary app preferences - 'Oxford Dictionary of English (British English)' and 'Oxford Thesaurus of English (British English)'. This worked as expected on my old MacBook - at the top of the main dictionary window, I would see buttons for 'All', 'Dictionary' and 'Thesaurus'.

On my new MacBook, I have unticked the 'Apple' and 'Wikipedia' reference sources which were initially on in addition to the aforementioned two British English dictionaries. But the main dictionary window shows only two buttons - 'All' and 'Dictionary'. When I go to the Dictionary app preferences window, the Thesaurus reference source has become unticked, and if I try to tick it, the checkmark is immediately removed!

Switching to the Dictionary and Thesaurus for American English works fine. I have the same issue in the Administrator account, which would appear to rule out a user-specific setting. I guess that one or both of the files for the British reference sources has become corrupt.

My (standard) user account is logged into iCloud, but the Administrator account is not. I didn't use the Migration Assistant to transfer any settings or data from my old MacBook, and I didn't copy any preference files - I just re-applied all the settings by hand.

Both MacBooks are running the most recent version of macOS Catalina (10.15.2).

I have tried unticking all the reference sources and re-starting, then attempting to re-apply the changes.

Does anyone recognize this behavior, or can you recommend troubleshooting steps? Is there some way I can delete and re-download the British English reference sources?

Thanks for any assistance.

1

0

You must log in to answer this question.

Browse other questions tagged .