1

OK, I tried following (OS X Yosemite) the instructions here

https://support.apple.com/en-us/HT203538

And I went into Terminal and typed in the following

diskutil resetUserPermissions / id -u

But now it's been showing a line of little rotating slash marks for a good couple of hours. I wondered if it's just one of those processes that takes a ton of time like when you do some kinds of file repair or whatever.

I also wondered what would happen if I interrupt this and try restarting. I have a TM backup so worst case I can restore from there and try again.

The Mac BTW is a 2010 Macbook Air. So it's about at the limit of what can run Yosemite at all.

  • Was there a problem with your user account file attributes that needing fixing? Also, my first thought for 2010 vintage Mac is: Is the original hard drive failing? – benwiggy Dec 30 '19 at 9:51
  • I tried permissions repair via disk utility, after interrupting the process. That seems to work--at least it tells me so. The drive is SSD - I guess it could be failing but I made a backup. The reason I was doing this is because I tried transferring the photos with migration assistant to a new mac (late model Air) and it said it couldn't repair permissions and transfer most of the photos. See this Q here (only partly answered) apple.stackexchange.com/questions/378560/… – Jesse Dec 30 '19 at 12:58

You must log in to answer this question.

Browse other questions tagged .