0

'Do Not Disturb' is set on an iPad Pro running ipadOS 13.3. It says "Calls and notifications will be silenced until Do Not Disturb is turned off" on the lock screen.

When someone calls me on Telegram, the notification still gets through, but in a weird way: before it's declined, instead of the Telegram call notification sound, I hear a regular call tone for half a second, and the screen lights up. Both are enough to wake me up, so 'Do not disturb' kind of fails it's purpose.

Here's what my 'Do not disturb' settings look like:

Screenshot

Is this an iOS bug, or is the app not honouring my 'Do not disturb' settings?

  • Does this answer your question? WhatsApp voice call overrides iPhone's "do not disturb" – fsb Dec 28 '19 at 14:42
  • Telegram and, in the case of the duplicate, WhatsApp, are apps and DND only affects the standard Apple features of calls and messages. – fsb Dec 28 '19 at 14:44
  • @fsb Are you sure about that? With DND enabled I don't seem to get push notifications from any app (which is why I think the answer to the other question is wrong). – nohillside Dec 28 '19 at 15:18
  • @nohillside I've only found DND to silence calls, emails, and messages. It won't silence timers or alarms. I've never had 3rd-party app notifications silenced so maybe it's just how I use it. – fsb Dec 28 '19 at 15:34
  • @fsb Now that I've tried: Call notification indeed do come through, even with DND active. Which of course lights up the screen etc. – nohillside Dec 28 '19 at 16:42
2

If your iPhone also received a telegram call - it will pass that off to all your devices if you have Calls on Other Devices enabled.

I would review the DND settings on your phone (or other iOS devices) and then verify you are OK with the Calls on Other Devices settings.

This is found in the settings app > Phone section in the calls subsection towards the middle on iOS 13.

Either way, pretty peculiar failure - I wonder if it's just slow to fail or that your call times out by the time the iPhone wakes your iPad and the call goes to "voicemail" and wasn't quashed at all other than slow wakeup wasn't slow enough.

  • I do have "calls on other devices" enabled, but at the time, my iPhone was in the airplane mode with all connectivity (bluetooth, wifi) disabled. – WhatHiFi Jan 5 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .