7

I am trying to work with Docker and a gui application and I need to use the xhost command.

I believe it used to exist but I don't see it. I also believe it is related to Quartz but running Quartz doesn't magically make the problem go away!

0

1 Answer 1

8

If XQuartz was installed previously, you have to enter the full path to xhost if the /opt/X11/bin folder wasn't added to your PATH or the system's PATH:

/opt/X11/bin/xhost

Run without any command line argument

... a message indicating whether or not access control is currently enabled is printed, followed by the list of those allowed to connect. This is the only option that may be used from machines other than the controlling host.

Further help: man xhost (or man /opt/X11/share/man/man1/xhost.1 if the /opt/X11/share/man folder isn't considered by manpath).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .