4

iMac mid 2014 has been working fine for 5 years (well, sort of since I made the mistake of upgrading to Catalina).

As of today:

  • start the mac
  • select a user from login screen
  • enter password
  • A few seconds elapse and then the cursor changes to the spinning colour wheel

At this point the UI is frozen. I have tried leaving it in this state for 24 hours to see if it clears, it does not. While in this state I can SSH into the mac and sudo kill -9 the login window daemon to get back to the user selection screen.

Tried so far:

If I can I'd like to avoid having to backup data via scp, wiping the disk and reinstalling from scratch - I've got better things to do with my life.

I also have no intention of visiting a Mac Store only to be told my a smug child that he's going to wipe the disk and reinstall.

Someone out there must know what specific breakage Apple and snuck in via auto update the night before and how to undo the damage, surely?

Hardware:

    Hardware Overview:

      Model Name: iMac
      Model Identifier: iMac14,2
      Processor Name: Quad-Core Intel Core i7
      Processor Speed: 3.5 GHz
      Number of Processors: 1
      Total Number of Cores: 4
      L2 Cache (per Core): 256 KB
      L3 Cache: 8 MB
      Hyper-Threading Technology: Enabled
      Memory: 32 GB
      Boot ROM Version: 140.0.0.0.0
      SMC Version (system): 2.15f7
      Serial Number (system): DGKLG0SXF8JC
      Hardware UUID: 78775D43-2857-5894-88AC-36ED44B3DE84

Software:

    System Software Overview:

      System Version: macOS 10.15.2 (19C57)
      Kernel Version: Darwin 19.2.0
      Boot Volume: Macintosh HD
      Boot Mode: Normal
      Computer Name: iSpartacus2
      User Name: Richard Hodges (rhodges)
      Secure Virtual Memory: Enabled
      System Integrity Protection: Enabled
      Time since boot: 23:03
10
  • Did you already boot your Mac with SIP disabled?
    – klanomath
    Dec 26, 2019 at 12:02
  • @klanomath no. Is there a way to check whether this is necessary? Dec 26, 2019 at 12:15
  • @RichardHodges Without log files/a full system report it's really difficult to investigate the failure. Disabling SIP and rebooting is a first step. You may also send me the full system report (zipped) and I will have a look (klanomath(at)googlemail.com). Additional diagnostic tests might be necessary.
    – klanomath
    Dec 26, 2019 at 12:25
  • If I understood the comments correctly, the problem started with Mojave and persisted with Catalina after reinstalling the OS. Out of curiosity: How did you reinstall the OS if you can't boot into a GUI?
    – nohillside
    Dec 26, 2019 at 14:29
  • 1
    @nohillside the computer does boot into a GUI, it freezes after you enter your password at the login screen. I reinstalled using recovery boot. Dec 26, 2019 at 17:44

1 Answer 1

1

Not really a good answer. In the end I had to nuke the entire disk and reinstall from the recovery partition.

I'll stay with linux going forward.

2
  • Could you be more descriptive about the approach? since I'm having the same issue with no luck Apr 26, 2020 at 14:26
  • @GayanPathirage I booted into the recovery partition and copied some onlne instructions on how to nuke the user partition and reinstall from scratch. Make sure you save important data first - you will lose it. Apr 26, 2020 at 15:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .