2

After update to Catalina, I got the following error message: "Verification Failed. An unknown error occurred".

Should I reset mac? v. 10.15.2

enter image description here

2
  • Welcome to Ask Different :) Make sure your Mac is connected to the Internet and the date/time are set correctly.
    – Nimesh Neema
    Dec 23, 2019 at 10:48
  • It is set correct
    – Bash Lord
    Dec 23, 2019 at 13:10

5 Answers 5

2

I had the exact same error. Here’s how I fixed it:

A corrupt Keychain can prevent multiple services from loggin in, including iCloud. Here is a way to figure out if your Keychain is the cause of not being able to login to iCloud.

  1. Open your Console app (under Utilities)
  2. In the Search field, type "Login"
  3. Press the Clear button.
  4. Try to login to your iCloud.
  5. Note the error messages. They may look something like this"

Error Domain=com.apple.accounts Code=13 UserInfo={NSLocalizedDescription=, NSUnderlyingError=0x7f*******c10 {Error Domain=com.apple.accounts.keychain Code=-25295}}}}

Break down the error codes:

Error Domain=com.apple.accounts Code=13

This code can be linked to Keychain errors with a simple Google search

Error Domain=com.apple.accounts.keychain Code=-25295

This error code (and many others) can be nterpreted at this link:

           https://krypted.com/lists/comprehensive-list-of-mac-os-x-error-codes/

In this case, 25295 is interpreted by pressing Command F and searcing "25295". The search locates the following code:

Keychain Manager error codes

errKCInvalidKeychain = -25295

All indications are that the Keychain is corrupt, blocking services from logging in. In fact, by searching your own Apple ID in the keychain to locate login keys, you might try deleting Public keys. In doing so, MacOS will fail to delete any key that is corrupt.

SOLUTION:

The solution is at this link: How to back up your iCloud Keychain

https://eclecticlight.co/2019/09/05/how-to-back-up-your-icloud-keychain/

If you backup your MacOS device, your Keychain is also backed up. The article describes how to ensure your iCloud keychain items are also included in any local backup, and in doing so, it also describes how to restore your Keychain. Your Keychain is located in a file within your Library at ~/Library/Keychains. In finder, you need to select GO at the top menu (there's a way to unhide the "Go" tab... I don't remember offhand, but it is easy to find). Library is under the GO tab. This being said, this folder is also backed up to Time Machine or any duplicate of your MacOS device. Follow the instructions in the link to restore the ~/Library/Keychains folder to your MacOS device. I restarted my MacBook Pro, at this point, and for the first time in a couple of weeks, was able to login to all services. Problem solved!

2

After removing macbook from list of iCloud devices I run this command in terminal and it resolved the issue:

sudo -v ; killall -9 accountsd com.apple.iCloudHelper ; defaults delete MobileMeAccounts ; mkdir ~/Library/Accounts/Backup ; mv ~/Library/Accounts/*.sqlite* ~/Library/Accounts/Backup/ ; killall -9 accountsd com.apple.iCloudHelper ; sudo reboot
2
0

In my case, I just

  1. Reset the keychain;
  2. Restart the MAC;
  3. Logged in again.

This procedure worked for me.

1
  • Please elaborate on what exactly "Reset the keychain" means (steps to do it, what it does).
    – swrobel
    Jul 18, 2020 at 22:13
0

I just had this issue and interacted with @AppleSupport over DM (which was a surprisingly pleasant experience), and these are the instructions they gave me that worked:

  1. Open Keychain Access.
  2. Search for "IDS" in the search field in the upper-right, then click the Keychain column to sort the items.
  3. For Keychain "login," delete all of the “IDS” items that are of Kind "application password"
  4. Repeat the above two more times, once for each of the following search terms: “FaceTime” and “com.apple.account”
  5. Search for “iMessage” in the search field in the upper-right. Delete all "iMessage Signing Key” and “iMessage Encryption Key”

After completing those steps, restart your Mac and try to sign in to iCloud again.

0

I had the same issue after an upgrade of Catalina to Big Sur 11.0.1. The only solution that helped me was in fact to reinstall Big Sur and create a new admin user.

But before I logged into https://appleid.apple.com/ and removed the device (in my case an iMac) from my account. Also make sure the phone number for the two-factor authentication is correct.

Then I restarted the iMac in recovery mode by pressing CMD + r immediately at boot time. At first I configured the connection to my wifi to make sure the installation routine can connect to the internet and get the newest version of Big Sur (In my case it downloaded and installed version 11.1). Then I selected "Reinstall Mac OS Big Sur". As first step create a new user with a different name and home directory the the existing one. In the following steps use your existing apple id to login. It should work now. But deselect the option "Allow user to reset password using Apple ID".

After the installation finished you must login with the new admin user. Using your Apple ID with the new admin user account should now work without problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .