0

The HD of my MacBook Pro (macOS Mojave) is encrypted with FileVault.

Yesterday, I created a new partition from the Macintosh HD (APFS) using the DiskUtility and called the new partition Data (Extended Journaled).

The problem is that now I cannot copy any files to the new partition. It seems that I don't have write permissions to write anything on the new partition.

enter image description here

enter image description here

enter image description here

enter image description here

Why is that and how can I fix it?

5
  • 2
    Can you add a screenshot from Disk Utility or the result of diskutil list to throw some light on your disk structure? The output of mount would help as well. Also, did you create the new partition on your main drive (and therefore reduced the size of the existing one) or on an external drive? – nohillside Dec 23 '19 at 10:33
  • I added some screen shots. By partitioning I had the choice between Partition and Add-Volume. I selected the Partition option. Not sure if this is the best option though. – user1941537 Dec 23 '19 at 12:37
  • okay. your question was misleading atleast for me. Your data folder is also on APFS but in your question, it was Extended Journaled. I will try to see this. – Udhy Dec 23 '19 at 12:43
  • It doesn't matter which file system. I can format Data partition to whatever file system but it's always Read-Only. – user1941537 Dec 23 '19 at 12:56
  • @user1941537: have you try this from terminal: sudo mount -u -w -v "/Volumes/Data" ? This should allow you to write. – Udhy Dec 23 '19 at 13:13
-1

I assume this happened as you have used the partition on Extended Journaled

Open the finder, find the drive under ‘Devices’, then right-click and select ‘Get Info’. A dialog box should pop up and display the basic info of the drive. At the bottom, there is a collapsed menu for ‘Sharing & Permissions’, make sure your username has read and write permission, and check "Ignore ownership on this volume"

enter image description here

If you are unable to do this , then first try to disable Journaling, and do the previous step shared above

Open Disk Utility, Select the partition and then hold down the alt key. Select the file from the top menu and you will then see an option to ‘disable Journalling’

2
  • 1
    How does the problem described in the question relate to "Extended Journaled" and ownership? How does enabling journaling cause access issues in the first place? – nohillside Dec 23 '19 at 10:30
  • I was able to enable "Ignore ownership on this volume" but it didn't help. I also added some screen shots to my original post, which might help. By partitioning I had the choice between Partition and Add-Volume and I selected the Partition option. Not sure if this is the best option though. – user1941537 Dec 23 '19 at 12:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .