0

I have some BlueTooth headphones that I have on most of the time I'm at my desk. However, sometimes I like watching something and throwing the audio to my HomePod. It works for what I need; however, it is always forcing me to reselect the HomePod as my Mac Mini's audio.

I have told my Mac Mini to use the HomePod as the default output in my Audio Midi Setup, but it doesn't seem to stick. When I turn on my headphones, and it connects, the audio goes there correctly. But if I power my headphones off or computer sleeps, it goes back to using the Mini's internal speakers.

Is there a way to automate this so that, basically, if my computer is ever on, it should look for the HomePod and only ever use it unless the headphones are connected?

Is this a weird thing to want? It's been driving me nuts! Thanks in advance.

  • Did you set the default audio output in System Preferences? – TimD Dec 23 '19 at 1:18
  • @TimD Heya. Yes, I've done that – anonymousacorn Dec 23 '19 at 13:26
  • 1
    Maybe see if you can put the Pod and internal speakers in an aggregate device, then mute the speakers. It probably doesn't stick to the Pod because of potential reliably issues. If I can find my Apple TV I'll see if I can replicate the issue. – TimD Dec 24 '19 at 11:29
  • @TimD Hi again, thank you. I appreciate it! Looking into adding the HomePod to an aggregate device; what do you mean by that, exactly? – anonymousacorn Dec 24 '19 at 17:25

You must log in to answer this question.

Browse other questions tagged .