1

I have bought a used MacBook Pro 2009 from eBay.

I have charged the battery to 100% (worked fine), and booted it. Everything worked, except that I can't boot when on battery. The battery itself is fine, so I can connect the charger, press the start button, and it starts. I can then disconnect the charger, and it will keep running. But without the charger, it will just not recognize the power button press.

I tried resetting the SMC (Shift+Ctrl+Option+Power Button), and resetting the PRAM (Cmd+Option+P+R like 5 times), but nothing changed.

Any ideas?

Update: Now it won't turn on even with the battery inserted, and it also does only charge if I try several times to connect the magsafe adapter

2
  • It's possible that a machine of this vintage has a fault with its power unit. See if you can find a local independent Apple repair technician. Alternatively, you might want to return it to the eBay vendor for a refund. – benwiggy Dec 22 '19 at 10:13
  • @benwiggy Thank you for your answer! The vendor sold it as broken, and I have some experience in repairing. But now I have finally found a fix. See my post. – Twometer Dec 22 '19 at 10:42
1

I have finally found a fix:

I left it overnight on the charger, sitting at a green light (100% charge). Apprently, that does a battery recalibration. Then, I was able to boot it from battery using the bootup pads on the mainboard. After then also cleaning of the keyboard connector (only like 3 keys were working) with isopropyl alcohol and some scrubbing, it finally worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .