2

Specs:

  • MacBook Pro, late 2019, 16-inch
  • macOS Catalina v10.15.2

About 50% of the time (and increasingly more now), when I wake my computer from sleep, the touch bar does not wake up. It doesn’t light up or react to touches — it’s just a piece of black plastic. This is usually fixed by a restart, but when my computer goes to sleep again it’s a crap shoot of whether the touch bar will wake back up again. It’s getting really annoying to have to restart my computer after almost every time I wake it from sleep, especially just to access essential controls like volume and brightness.

Here are some things I’ve tried that didn’t work:

  1. Force-quitting the TouchBarServer from the Activity Monitor
  2. sudo pkill TouchBarServer
  3. pkill "Touch Bar agent"
  4. Resetting the SMC (shutting down, holding power button for 10 seconds until the fans spin, and then booting up again)

One thing I did notice is that the touch bar turns back on when I log out of my account or switch accounts, and when I log back in to my account again, the touch bar turns back off. This is really weird because I can’t think of a reason why this would be related to my user account. I haven’t tried deleting my account and creating a new one, because that’s a lot of work and I’m not sure it would even fix the problem. But I would be willing to do that if I knew it would definitely fix it.

I tried searching online but found nothing; it seems the community hasn’t come across this problem yet. Is this likely a common problem with new MBPs or Catalina, or is it just the luck of a draw with my machine?

  • Have you tried NVRAM reset too? – Udhy Dec 20 '19 at 9:28
  • @Udhy no, can you point me to a source that explains what it is and how to reset it? – chharvey Dec 20 '19 at 15:55
1

I recommend you to reset NVRAM of your MBP.

This chip stores information on screen resolution and can often become corrupted. You can reset it by starting your Mac while holding down cmd + opt + P + R . You should hear the Mac chime, restart and chime a second time. Then you can release the keys you are holding.

More info here.

| improve this answer | |
  • Thanks for your answer. I haven’t tested this yet but once I do I will let you know if it works. – chharvey Jan 2 at 4:29
  • This just happened to me, first time this morning. Macbook Pro running Catalina. Did you find a fix or is it back to the Genius Bar for another sit down and wait? – macasas Feb 4 at 8:53
  • tested this. did not seem to work. – chharvey Mar 3 at 22:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .