1

The doc covers the bottom of each application that is not maximized.

Particularly in an application like the terminal, I need to get work done in that part of my screen. As you see in the image, my prompt, where I have typed "echo 4," is simply covered by the dock. I then have to manually resize the window just to get it out of the way of the dock.

I know I can automatically show/hide the dock, but I'd rather it was visible, yet not interfering.

enter image description here

9
  • apple.stackexchange.com/questions/5327/… you can also minimise it and set animation for hovering. – anki Dec 18 '19 at 9:29
  • Thank you. By "minimise it and set animation for hovering" do you mean "Automatically hide and show" from Settings. I did that, but I would like it to be available, as can be done in Ubuntu and Windows. (This means that the screen real estate is simply taken by the dock. Npthing can go above/below it.) – Joshua Fox Dec 18 '19 at 11:43
  • no @joshua , I meant reduce its size and use animation to magnify it when you hover over it. or get accustomed to dock on the right, (of the left for that matter, but most apps have controls on the left) – anki Dec 18 '19 at 11:55
  • @JoshuaFox: If you open the Dock preferences (Command + Space, type in Dock, push enter), then alter the Dock to be on the left/right side of the screen, and then alter it to be back on the bottom, it will stop covering your application. Give a try. – Udhy Dec 18 '19 at 12:18
  • Udhy, I did that --same problem – Joshua Fox Dec 18 '19 at 12:31

You must log in to answer this question.

Browse other questions tagged .