2

I formatted a 128 GB micro SD card from the factory in a National Geographic Explorer 4 4K 30 fps (a camera like a GoPro). It recorded video and I can play it back. On macOS Mojave 10.14.6, I get the warning:

The disk you inserted was not readable by this computer

Initialize Ignore Eject

I am confused because I have transferred data from another micro SD card and the same camera, and because the disk on Disk Utility shows as

disk3s1
USB Internal Physical Volume • ExFAT
127.85 GB

and ExFAT is a format offered by Disk Utility when formatting a drive.

I have run Disk Utility First Aid on the Apple SD Card Reader Media, which succeeded, and on disk3s1, which failed with this log:

Running First Aid on “” (disk3s1)

Repairing file system.
Volume is already unmounted.
Performing fsck_exfat -y -x /dev/rdisk3s1
Checking volume.
Checking main boot region.
Main boot region is invalid.  Trying alternate boot region.
Checking alternate boot region.
Alternate boot region is invalid.
The volume  could not be verified completely.
File system check exit code is 1.
Restoring the original state found as unmounted.
File system verify or repair failed.

Operation failed…

How can I recover the data from the disk?

Update: I tested the formats on macOS Mojave 10.14.6 and the camera:

  • macOS cannot read the ExFAT format when a card is formatted by the camera
  • the camera cannot read the ExFAT format when a card is formatted by macOS
  • the camera can read and write to a card formatted in MS-DOS (FAT) by macOS (launch Disk Utility, click on the volume, click Erase, then choose Format: MS-DOS (FAT)).

I will format every card on the computer first before using it on the camera. For the current data on the card formatted by the camera, I will try on a windows computer this weekend.

  • 2
    Transfer it over WiFi then format on the Mac. Test. – Tetsujin Dec 17 '19 at 18:37
  • 1
    That camera may happily use a "windows" formatted disk, which the mac can also read/write to, but the mac cannot read the camera's own format... – Solar Mike Dec 17 '19 at 18:44
  • @Tetsujin Brilliant! I couldn't find the host IP as arp -a stalls and returns nothing, and the user manual has nothing about it either. Do you know the usual IP address? Or does it use a different protocol? – miguelmorin Dec 17 '19 at 18:57
  • tbh, I just googled so far as to discover it could in theory transfer over wifi. I'm afraid I don't know any details as to how it works. Try grab the manual online. – Tetsujin Dec 17 '19 at 19:40
  • 1
    I don't know if GoPro supports Wi-Fi, (I've used it only for nikon D5300 or 5300D I forgot and one canon DSLR). Camera sets up a Wi-Fi network of itself and then the app provided by the company is used to get the photos on iOS and then to Mac. @Tetsujin did you mean directly to Mac ? – anki Dec 19 '19 at 17:43
1

The solution was to use a Windows computer with an SD card socket to read the card and transfer the files.

Before that, I tried the following methods mentioned in the answers and the comments. The YUTU PRO smartphone application could transfer small files and not large ones (more details below). The retailer had no idea about the problem or solutions. I did not try @BaconDuctTape's MiniTool recommendation as Windows had solved the problem.

For the future, I will format any card with MS-DOS (FAT).

more details on YUTU PRO app

I followed the directions on the user manual. I was lucky that one file was small enough for the phone's available space; unlucky that the second transferred but failed to show and lingered somewhere (a common ghost file problem). The app showed two videos with duration 00:00 when they have 06:49. The app alone was taking 3.3 GB and has no menu option to delete its data. Rebooting the phone clears the YUTUPRO ghost data (hint from here).

Then I deleted all photos from the phone, downloaded small files (around 3 minutes of footage) one by one from the app to the phone, transferred to the computer, deleted the file on the Photos app, went to Albums > Recently deleted to delete permanently, and started again.

For files at the maximum of 6:46, which showed as 0:00, the app was able to play them by streaming, but not to transfer them. The app showed "Downloading, Please Waiting ..." (sic, see below) for several hours. So I went for the Windows solution.

enter image description here

| improve this answer | |
0

I've used MiniTool's data recovery software on Windows and had very good success. I haven't tried their macOS version but it should hopefully be just as good.

https://www.minitool.com/data-recovery-software/free-for-mac.html

| improve this answer | |
0

After confirmation in comments and looking up the manual:

If the app supports taking out media on phone via Wi-Fi, they can later be transferred to Mac via photos app.

First, install the app on your smartphone. Look for „YUTUPRO“ in the AppStore or Google Play Store. After installation, you need to activate the Wi-Fi [icon] of your camera via the speeddial menu (fast touch movement downwards). Connect the camera to your smartphone (find a network with the name displayed on the camera e.g. „4K Sports DV“. Use the password „12345678“. Start the action camera app now.

https://www.bresser.de/out/media/e6d43e3ebf394363ac88f393210e4237.pdf

https://www.bresser.de/en/Sport-Optics/Game-Cameras/Action-Cams/NATIONAL-GEOGRAPHIC-4K-Ultra-HD-30fps-WIFI-Action-Camera-Explorer-4.html

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .