9

I have setup a new Mac with iTerm and the hotkey window shortcut (MacOS Catalina).

It all works well, except that the hotkey window does not take the focus when it opens. I mean that I can type commands rightaway, but the active application does not change.

E.g. if I am in Firefox and hit the shortcut, then the Firefox menus are still active.

The problem with that is that my IDE (Intellij) does not register that the focus changed to another app, and does not save file changes or refresh files from disk, which makes programming very difficult.

I know it used to work on my former machine. I suspect I need to configure iTerm correctly.

Here is how the hotkey shortcut is configured:

enter image description here

1 Answer 1

14

This one had me too. Just untick "Floating window" and restart iTerm2.

Full directions:

  • MENU: iterm2
  • MENU ITEM: Preferences...
  • TAB: Profiles
  • LIST ITEM: [Your Hotkey Profile Name]
  • TAB: Keys
  • BUTTON: Configure Hotkey Window
  • CHECKBOX: Floating Window <= UNCHECK THIS

enter image description here

6
  • 5
    Thanks! I did have to check an extra checkbox in "Advanced": "The hotkey window floats above other windows", else the hotkey window wasn't visible. Commented Dec 26, 2019 at 20:35
  • 1
    thank you guys Mike and @MatthieuNapoli, you saved my day, was trying to figure out that long time Commented Feb 3, 2022 at 8:27
  • 1
    i dont see that as a solution because then you lose the terminal when you click on other displays.
    – dtc
    Commented Dec 18, 2022 at 1:17
  • @dtc I believe you're looking for "Pin hotkey window." It's pictured in the screenshot above. Commented Dec 19, 2022 at 10:06
  • 1
    Big thanks for providing this simple fix! It saved me a lot of hassle trying to find other workarounds.
    – flashjpr
    Commented Jul 22, 2023 at 12:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .