1

tmutil not only stores Time Machine snapshots, but also snapshots for other applications. E.g.:

~% tmutil listlocalsnapshots /
com.econtechnologies.chronosync.236A7A4F-5F96-4F99-8559-57D3965BF6BA.1575374525

This is a snapshot from a backup/sync application called ChronoSync.

My question: How can I determine the size it takes on my hard disk, and how can I delete it?

I'm using High Sierra, and there is no hidden /.MobileBackups folder, nor is anything (other than my hard disk) mounted at /Volumes.

Edit: I can mount the snapshot using the following commands:

~ » sudo mdkir /tmp/snapshotbackup
~ » sudo mount_apfs -s com.econtechnologies.chronosync.236A7A4F-5F96-4F99-8559-57D3965BF6BA.1575374525 / /tmp/snapshotbackup

From there, I can determine the size:

~ » sudo du -sh /tmp/snapshotbackup/
204G

Clearly, this is a stray snapshot that is causing my disk to fill. However, that 204G is so large (on a 250 G disk), that is surely contain files also present on my hard disk (I kind of assume APFS uses hard symlinks here). However, I'm hesitant to delete and files from /tmp/snapshotbackup/ fearing I may thus delete (hardlinked) files from my regular disk (not likely, but I prefer to be cautious).

So I still have the question how can I determine the size this snapshot takes on my hard disk, and how can I delete it?

9
  • Note: I can't seem to locate the file on High Sierra (it's not mounted under /Volumes. Perhaps it's not stored as a file, but as a APFS snapshot?). And I can't delete it because tmutil deletelocalsnapshots takes a date as argument, and assumes the name of the snapshot starts with com.apple.TimeMachine., which is not the case here.
    – MacFreek
    Dec 17 '19 at 10:01
  • I don't think you want to delete anything from the Chronosync snapshot. I think the Chronosync snapshot works differently than the tm snapshot (both use APFS' snapshot feature though). The Chronosync snapshot is a snapshot of your whole system at some past point of time. The "overhead" is the diff to the current state of your system (=all files & folders changed since). The TM snapshots are just the (hourly) diffs.
    – klanomath
    Dec 17 '19 at 10:49
  • @klanomath: for clarity, I prefer to delete the snapshot altogether, there is no need to delete specific files (although that may be a workaround for me). So far, neither works :(
    – MacFreek
    Dec 17 '19 at 12:37
  • How much space is used on your internal SSD officially?
    – klanomath
    Dec 17 '19 at 12:44
  • According to the Finder and System Information app, 247 GByte (out of a 251 GByte disk). According to du (diskusage) or WhatSize (3rd party application) about 185 GByte. So there is a 60 GByte gap between what's present in the file system and what's available on disk. A quick check shows that it's not in other (hidden) partitions, so it is likely in this snapshot. This seems to agree with the results I've seen so far.
    – MacFreek
    Dec 17 '19 at 14:40
2

I received a reply from the author of ChronoSync, and he helpfully explained the following option to manage snapshots.

To list snapshots:

diskutil apfs listSnapshots /

To delete snapshots:

diskutil apfs deleteSnapshot / -name <name_of_snapshot>

This seems the better option, which unfortunately doesn't seem listed elsewhere (all other guides I found only mention tmutil). I couldn't test, since I already deleted it with CCC.

2
  • In theory in works ;-): while running a trial sync (in a VM) the deleteSnapshot command would have worked if I had the permission to. The snapshot is in use and I'm not allowed to delete it (even with root privs).
    – klanomath
    Dec 17 '19 at 17:06
  • I had to search the web extensively to find this. Thank you! It worked perfectly to delete a leftover snapshot that a backup app had created by accident. Nov 6 '20 at 22:23
1

The only tool that I am aware of that will allow you to easily view / delete APFS snapshots is Carbon Copy Cloner.

The app is meant to clone your hard drive, but it also has an interface for viewing / deleting snapshots, as shown here:

Screenshot of Carbon Copy Cloner.

Select your drive under “Volumes” on the left and the right column will populate with all of the snapshots (I don’t happen to have any non-Time Machine snapshots, but it will show those too).

2
  • Thanks! Almost to my surprise, CCC was able to delete this snapshot without any issue, and the available disk space increased from 2.5 GByte to 52 GByte in half a minute. Wow. While I don't expect to use CCC more often, I immediately bought it (€45 with VAT). Worth it.
    – MacFreek
    Dec 17 '19 at 14:59
  • I’m glad it was able to help. It’s a very good tool for making a clone of your boot drive, which I definitely recommend that everyone should have, but I trust you can make your own backup decisions :-)
    – TJ Luoma
    Dec 18 '19 at 12:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .