I'm having a puzzling issue with a website on macOS server (server.app 5.6, High Sierra 10.13).

All works fine when the url length is below 70 characters. 70 and up and I'm getting a Proxy error. The actual absolute path char count respectively <= 94 - works, > 94 - Error

enter image description here

Can there be a limit set somewhere?


Seems to be related to change of the PHP from system to Homebrew.


The OS PHP version shipped with the Server.app is 7.1.32 – it works but is missing the intl extension that I need for a Magento 2.3.3 project
(I think intl is shipped with the Server.app or MacOS/Xcode but inactive by default)

The Homebrew PHP version that I was trying to use: 7.2.25

The MySQL version: 8.0.16 (Oracle community) The MySQL actually says that it's compiled for MacOS 10.14 and I run MacOS 10.13, not sure if that is important)


After more testing I noticed the error pops-up also with shorter, simple urls, random pages, without any pattern really (when using Homebrew PHP).

I've compared the php.ini from OS and Homebrew installations with a diff but failed to find any significant differences. The error appears even on a simple Wordpress websites that don't use any of the advanced php extensions.

I've got the same Homebrew PHP installed on my other Mac, same OS but also Homebrew MySQL and without the proxy – it works fine.

  • Also if someone had an advice on how to disable those proxy errors showing-up on front-end...
    – Maciek Rek
    Dec 16, 2019 at 20:24
  • 1
    Don't shoot the messenger! The error is probably related to your website and an application server (e.g. TomCat, JBoss etc.) or a database linked to it. What kind of website are you hosting?
    – klanomath
    Dec 17, 2019 at 15:01
  • 1
    Which setup guide/how-to did you follow to set up Magento (& MySQL/PHP)? I will try to reproduce the error in a VM...
    – klanomath
    Dec 18, 2019 at 22:48
  • 1
    More important: did you setup the "new" website in the "server root" (/Library/...) with the Server.app or as normal website in the standard apache root at /private/.... But checking older questions of yours you've probably chosen the Server.app path.
    – klanomath
    Dec 19, 2019 at 7:16
  • 1
    I tried to simulate your problem in a VM but failed almost completely - the admin link after successfully setting up Magento timed out (I used brew-php72 /MySQL 8.0.16/the composer method to install Magento/made some adjustments to the admins PATH variable/modified the sites config file in /Library/Server/Web/Config/apache2/ to use brew's php72 - apparently I did something wrong). It would require to know all the mods you made (PATH/config etc. and the whole proxy config - quasi the whole recipe) to solve your problem.
    – klanomath
    Dec 21, 2019 at 12:04

1 Answer 1


Trying to get to the bottom of that... most likely the issues are related with the specific configuration of the bundled Apache server on MacOS.

I think the only solution would be re-installing Apache with eg. Homebrew, which is effectively migrating away from the outdated Server.app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .