2

I often have to type "weird" characters so I turned on the keyboard menu in macOS. Since upgrading to Catalina, it has disappeared and I cannot get it back.

In Settings->Keyboard->Keyboard I have "Show keyboard and emoji viewers in menu bar" turned on.

In Settings->Keyboard->Input Sources I have "Show input menu in menu bar" turned on.

There is no menu item. Force quit of Finder and reboot did nothing.

Any suggestions?

1

I have also run into this problem, so far with no solution. There is however a workaround, from the question linked in the comments, which helps.

cmd-ctrl-space (⌘^␣) will bring up a quick emoji picker. There is an icon at the top right (circled in red) that will switch you to the system character viewer.

Emoji picker w/ character picker highlight

Once you have switched to the character viewer, you can navigate and insert characters as you normally would, just as if you had opened it from the input sources menu. Happily, once you have switched from the emoji picker to the character viewer the system will remember this choice, so the next time you hit ⌘^␣ you will get the full character viewer instead of the emoji picker.

It doesn't address the missing input sources menu, but for the specific task of adding non-standard characters I find it to actually be faster.

If you happen to know the code points you can also enable the 'Unicode hex input' input source. You can't switch the via the input sources menu, but you can use ctrl-space (^␣) to switch between enabled input sources. With the unicode hex input source enabled, opt-xxxx where xxxx is the code point number will insert a character.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .