4

On my work computer's Apple ID I only sign into "Media & Purchases" - to access my Music library. I don't have a reason to sign into "iCloud" and prefer to keep my personal iCloud off of my work machine.

Unfortunately (on macOS Catalina) the cost of this is that System Preferences has a permanent badge icon and I'm prompted to add iCloud every time I open System Preferences.

How can I turn off this warning without signing into my personal iCloud account?

Some solutions I've considered:

  1. Use iCloud, but toggle off all syncing.
  2. Create dummy Apple ID just to sign into "iCloud" (keep my regular Apple ID for "Media & Purchases").
7

You could also issue this command in the Terminal:

defaults write com.apple.systempreferences AttentionPrefBundleIDs 0; killall Dock

This has worked for me so far (I'm on 10.15.2). Before that I created an alias for System Preferences, and put that in the dock instead. You get a small arrow at the bottom of the icon, but it's less eye-catching than the nasty red blob.

| improve this answer | |
  • 1
    Thanks for the info! I found some more about this here: apple.stackexchange.com/q/344278/151404 seems like it turns of the badge for all system prefs notifications (until the next time it checks for an update, which is often for me)? While this is a potential solution, I actually like being notified of available updates to macOS (therefore eliminating the alias option as well ). Additionally, I’ll still be prompted to connect my iCloud account when opening system prefs. Did I miss anything? – JBallin Dec 19 '19 at 16:52
  • You will still be notified of system updates through the standard pop-up notification on the top-right of your screen. There's no modal prompt for iCloud when opening System Preferences, just a line saying "Start using iCloud", for me that's acceptable! – MrBigglesworth Dec 20 '19 at 8:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .