I've been having this issue for the past few months, where my Mac will echo type whole/partial words while I'm typing. This isn't the same issue as double typing keys, but rather whole phrases will appear again in the middle of me typing. It looks something like this:

"Hello ello world!"

Sometimes it will execute a command to close a window twice.

This goes away when I'm in "Safe Mode". Does anyone have any clue where this is coming from?

I don't think this is a keyboard issue, honestly. Well, maybe a buffering issue? I contacted Apple Support and they didn't have much to say. I reinstalled the operating system, and it still comes up. Though, it did seem to largely go away for a few days.

Additional Details: Running Catalina 10.15.1 (Happened on previous versions of Catalina too) MacBook Pro 2017 13inch

  • Does this happen only in specific apps, or across the whole system? Have you tried using a new or guest account and seeing if it still happens?
    – daGUY
    Commented Dec 15, 2019 at 16:38
  • 1
    Do you have external keyboards connected or any macro software like keyboard maestro running? Maybe try running Karabiner's event viewer and typing around a bit to see what's happening. Also, in settings > keyboard > input sources, check "show input menu in menu bar" and then click the menu item > show keyboard viewer. This allows you to see what's being typed while you're typing. Commented Dec 15, 2019 at 19:42
  • Thanks for the comments, and sorry it's taken me a while to get back. Holidays have kept me busy. Yes, this happens across the whole system, and not just in Safari or Notes.
    – Joel
    Commented Jan 5, 2020 at 14:42
  • @TalosPotential, thanks for the input. The keyboard viewer is a handy tool that I didn't know about. I''ll use it to keep an eye on the inputs as I work. Unfortunately, everything seems to go too fast for me to catch it when it happens. I'll check out Krarabiner's even view when I get the chance.
    – Joel
    Commented Jan 5, 2020 at 14:48

5 Answers 5


There appear to be many variations on this question, that I have found.

However the problem addressed in this question is the one that I was experiencing.

So I'd like to try to post here a comprehensive answer that addresses the best possible solutions that have come up so far, starting with all the most common, simplest and least likely to work suggestions up to the ones that seem to address this problem specifically.

Note: If you've done your research, you'll note already an enormous amount of overlap with multiple pages linking back and forth to one another, in regards to this issue. My attempt here is simply to aggregate as many of the key factors involved into one place.


So for a long time now, MacBook users have reported a 'double typing' issue, most especially with the most recent MacBook Pro's to hit the market. There have been many reports of this problem occurring on 2015, up to 2019 edition MacBook Pros, from the 13' to the 15' Touch Bar, and every thing in-between.

There appear to be multiple similar problems, that may or may not have more than one possible solution. The most common reported issues I have seen are:

  • single keys such as b or n being pressed and outputting doubles like bb or nn in their place. Space bar is also commonly reported to be double typing.
  • some people may also be irked by the default setting of a double space autocorrecting to a period ..
  • instances of multiple repeated strings or sequences of keystrokes, at seemingly random intervals, for example whole words, or even multiple words appearing twice, and also modifier commands such as: +w or ctrl+tab.

In my case the problem was the latter. I'm sure other variations of this problem exist, these are the ones I've encountered most frequently in my search for a solution.

Possible Solutions

This is a summary of most of the answers that I have come across so far, hopefully one of them will work for anyone who is experiencing this problem.

  • System preferences -> keyboard = Slide the bar left to turn 'key repeat' to off. This is one of the most common solutions as it is by far the simplest and quickest to try. It's also the least likely, from what I've gathered.
  • cleaning your keyboard, as per these instructions there's even an app to help you do this
  • turning off the period autocorrect option = System preferences -> Keyboard -> Text: Uncheck "Add period with double space"

This problem has become so substantial that Apple has released an extended service specifically for this problem, whereby they are replacing keyboards free of charge for anyone who's device falls within their approved list, which as of Jan 2020 includes all Mac products using the butterfly keyboard.

Like many others however, it seems to be increasingly clear that for most people (though not all) this is not a hardware issue. Many users, including myself, have testified that this occurs not just on the Mac keyboard, but external keyboards also, wired, wireless and bluetooth alike.

Most significantly this problem appears to have started for many, only after installing Catalina.

Users have reported that the problem disappears when:

  • Running their Mac in 'safe mode'
  • In other user accounts on their machine (this is true in my case)

So a number of other suggestions have also popped up. For those who believe that their problem is software related, the following solutions may work for you.

  • Install an app called Unshaky
  • Reset your NVRAM as per a comment from this other question
    • option++P+R
  • Update to the latest version of macOS Catalina (version 10.15.3 as of the time of writing) -- System Preferences -> Update Software
  • Create a new user account
  • Re-Install MacOS in the Background
  • Roll back to the previous MacOS, Mojave
  • And the worst case scenario - A full wipe of your system and re-install a fresh version of your MacOS

For anyone who has Wacom tablet software installed

this Reddit post appears to have isolated a fairly specific problem, but it appears to have fixed the problem for a lot of people, and makes intuitive sense to me, for anyone who has Wacom Driver software in their system.

  • Install the most recent Catalina compatible Wacom software from their website --(This is what solved the problem for me)
  • Uninstall any Wacom drivers you may have installed on your system. Official instructions can be found here
    • disconnect tablet from USB
    • Navigate to: Finder -> Applications -> Wacom table -> Wacom Tablet Utility
    • Click the 'Uninstall' button
    • Restart your machine
    • Find and delete all related folders as per the linked instructions


Finally, I'd like to acknowledge the multiple posts and pages that I have drawn on to find this solution. I can't take credit for any of the solutions posted here, I found them all in my efforts to fix my own frustrating problem. I hope that anyone experiencing this problem finds a solution in this answer.

  • 1
    Thank you for the very comprehensive answer to my question.
    – Joel
    Commented Feb 9, 2020 at 16:53
  • 1
    No problem at all. This is a really annoying problem, it's the least I can do. Commented Feb 10, 2020 at 5:09
  • 1
    Just commenting to say thanks for the detailed answer! Commented Aug 11, 2020 at 14:27
  • 1
    Thank you very much, it really. solved my headache of double typing of some letters. For me, System Preference -> keyboard -> slid to left option worked. Commented Jul 27, 2021 at 5:13

Uninstall Wacom drivers.

I had the exact same problem.

Kudos to DryLabRebel for their comprehensive reply to this question, but the first thing to try is this:

Uninstall Wacom drivers.

C.f.: https://www.reddit.com/r/MacOS...

  • 1
    Or update them to the latest versions. Commented Feb 26, 2021 at 3:27

It could be either a software or hardware issue.

I recommend you read this OSXDaily article:

Locate the “Key Repeat” slider setting and adjust it to the “Off” position


If the Mac is still double typing characters and spaces, the next thing you should do is clean the Mac keyboard, which can be made easier with an app called ‘Keyboard Cleaner’ that temporarily blocks the keys on a computer so that they can be pressed down without inserting any characters.

If these steps don't help you can try an open source app that debounces keys until you can get the keyboard replaced:

  • 1
    Yeah, I did run into that article while I was trying to resolve the issue, and I did make the adjustment to the Key Repeat slider. The difference here is that it isn't a single key that repeats, but whole words. I believe it is a software issue, since it disappears when I'm in safe mode.
    – Joel
    Commented Jan 5, 2020 at 14:41

I had the same issue on the spacebar of my Macbook 12". Download the unshaky app at http://unshaky.nestederror.com It works wonders. You can also set each key repeat delay individually. Recommended is 40ms so you can just set the keys which pose you a problem.

  • Thanks for the tip! I'll look into it.
    – Joel
    Commented Jan 25, 2021 at 22:36
  • I'm using 20ms and 80ms for few keys which tend to repeat. Works great.
    – Rexcirus
    Commented Apr 14, 2022 at 14:13

TLDR: Thoroughly scrub Wacom from your computer--there is a lot of scrubbing to do, so even/especially if you uninstalled it, read further! I'd uninstalled Wacom tablet driver some time ago, so of the possible causes, I doubted this was my issue. I decided I "may as well" check if it left any artifacts and clean them up anyway... then saw just what it had left. and I thought "Oh my! this looks like stuff that could break your keyboard." then, slowly, "oh god oh god I'm never letting Wacom touch me again. I must warn the others."

Step 0: Uninstall the app, from within the app if possible.

As I mentioned, I had already uninstalled Wacom Tablet Driver. So I can't remember if the app has an "uninstall" function, or if I simply dragged it from Applications to Trash, the usual process on a Mac. It seems sociopathic to me to write software that leaves a mess like this without including a way to clean it up, but sloppy software is often sloppy in more than one way. Therefore, I recommend:

Check if the Wacom application includes "Uninstall" in the menu, and use it if available. Otherwise, put it in the trash, then permanently delete it. No matter which way you uninstalled it, complete steps 1 and 2.

Step 1

Check that its accessibility permissions are gone. In the GUI: apple > System Preferences > Security and Privacy > Accessibility > Remove Wacom from program list.

Step 2: Find and rm remnants

In Terminal:

sudo su
find /Library -iname *wacom*

I checked the folders ~, /Library, and /Applications (System/Volumes/Data might be worth checking too.) I found over 50 files including but not limited to

/Library/Internet Plug-Ins/WacomTabletPlugin.plugin
/Library/Preferences/Tablet/Wacom App Specific Settings/ArtRage Studio Pro.wacomas (and many other programs I'd never used)
.plist everywhere
/Library/StagedExtensions/Library/Extensions/Wacom Tablet.kext
/Library/Extensions/Wacom Tablet.kext

For me, the problem seemed to get fixed by this filesystem cleanup very early on (something in ~/Library or /Library most likely.) It was memorable because it was happening to me at almost per-sentence frequency, but I could soon type commands without them repeating.

Step 3 (or 2b?): How to delete kernel extensions

Notice Library/Extensions/Wacom\ Tablet.kext/ in step 2? Well, let me save you some "can't rm in sudo mode?" googlin': How to delete kexts in Catalina?


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .