2

I was watching some youtube videos on my mac (macOS Catalina, MacBook Air, 13-inch, Mid 2012) with my paired Bluetooth headphones. Randomly, about 15 minutes in the audio output just switched to the internal speakers. Went into audio preferences and tried to select my headphones as audio output but it wouldn't change where the audio was playing from. I then disconnected and reconnected the headphones and it worked for around another 15 minutes, and then the same thing happened. I have experienced this issue multiple times with both my headphones and a pair of wireless earbuds. Both the headphones and the earbuds work with my iPhone 6 with no problems at all. Does anyone know a way to stop this from happening?

1

This kind of issue has been widely noticed after the major updates of macOS from Mojave to Catalina. I would suggest you get the latest Catalina update that has been released couple of days ago. In other hand, try the following two resolutions which might help you.

  1. Open Finder
  2. Click on “Go”
  3. Then go to “Folder”
  4. Type on the search tab ’ /Library/Preferences’
  5. Look for a file with a filename “com.apple.Bluetooth.plist.
  6. Delete that file. Not to worry though as will auto-create a new copy of the Bluetooth file.
  7. Once file is deleted, restart your Mac device.

PRAM or Parameter Random Accessory Memory that stores system settings on your Mac device such as settings on display, volume of your speakers, time zone settings and many others. Here’s how to reset PRAM on Mac:

  1. Shut down your Mac device.
  2. Press the Power Button.
  3. Before the grey screen appears, press the Command, Option, P, and R keys all at the same time.
  4. Continues pressing the keys Mac restarts and a startup sound can be heard for the second time.
  5. Finally, release the Four (4) keys: Command, Option, P, and R keys
| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .