I have macbook air 2015 on Catalina Version 10.15.2 . So previously I had ran into this issue MacBook filesystem FFFFFFFF-FFFF-FFFF-FFFF-FFFFFFFFFFFF after deleting linux partition and thank god I fixed it but I was not able after that to boot into windows 10 it was entering in recovery screen with error code 0xc00000e. So I deleted bootcamp and tried to reinstall it. I download latest windows 10 64 bit iso file and when I tried to install it via bootcamp it says Disk Could Not Be Partitioned! enter image description here I tried running first aid from disk utility but it says that there are no problems. I just don't know what to do any help would be appreciated!

macbooks-MacBook-Air:~ macbook$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         250.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +250.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD - Data     145.4 GB   disk1s1
   2:                APFS Volume Preboot                 82.4 MB    disk1s2
   3:                APFS Volume Recovery                528.5 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
   5:                APFS Volume Macintosh HD            11.0 GB    disk1s5

macbooks-MacBook-Air:~ macbook$ 
  • Add the output from the Terminal application command diskutil list to your question. Dec 11, 2019 at 11:42
  • @DavidAnderson I have added output! Dec 11, 2019 at 20:08
  • I would have to say you have three possible directions to go. 1) The error message is wrong and there is actually something else wrong. For example, maybe there is still Windows boot code in the EFI partition. 2) There is something wrong that can not be fixed and you may have to do a clean install macOS. 3) You can try to manually install Windows 10, which I assume at some point you will discover what the problem is. I can help if you choose to go in directions 1 or 3. Dec 12, 2019 at 13:36

3 Answers 3


The same issue with the latest Cataline 10.15.3 and two SSD Fusion Drive (internal 24Gb + 512Gb WD placed instead of HDD), made with command "diskutil resetFusion" which is related to Catalina or later OS.

Hello Apple.


I have struggled with this for quite a while, so I'll leave my solution here in case someone is dealing with the same. I came up with the solution after joining some answers here and there. It ended up being overallocation warnings on my disk that were preventing bootcamp to be able to do the partition. Test if you can add a partition on disk utility. In my case it failed, and I could see the overallocation warnings there. So here's my solution:

  1. restart mac os and press cmd+r to enter recovery mode
  2. open terminal
  3. run cmd diskutil list - to check your disk identifier, mine is disk0s2
  4. fsck_apfs -ln /dev/disk0s2 - optional: if you just want to check your volume to make sure you have issues. This also resulted in overallocation warnings.
  5. given the overallocation warnings, we can use fsck_apfs to fix them, but if you just run the command, it will throw the error that your container is mounted with write access.
  6. You'll need to unmount you disk with: diskutil unmountDisk /dev/disk0s2
  7. Now that your disk is unmounted: fsck_apfs -oy /dev/disk0s2 (-o to repair overallocations, -y to answer yes to questions, i.e always attempt to repair any damage that is found)
  8. Once finished mount your disk again: diskutil mountDisk /dev/disk0s2
  9. You can check again if overallocation errors are gone with command of 6
  10. Restart your machine, you should be able to go through bootcamp assistance and it should be able to partition your hdd.

If you get permissions error, run commands with sudo.


If you happen to have a Fusion drive, this worked for me https://support.apple.com/en-gb/HT207584

Strange this is happening (to myself as well) on Catalina when Mojave's most recent update specifies it fixes this

  • Actually I checked and I don't have fusion drive. It is SSD . Dec 12, 2019 at 13:10
  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the link you provided will answer the question. Answers should be self-contained so others can find them by using the search feature. Links can change and become outdated so we prefer the answers to not just be a link. See How to Answer on how to provide a quality answer.
    – fsb
    Dec 12, 2019 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .