The new data protections in Catalina make some folders inaccessible by default (for example the 'Documents' folder). When an application tries to access one of these folders the OS presents the user with a dialog box to ensure they intended the access.

See the Data Protections section here.

This seems to have had the effect of breaking home folder network shares. If you enable file sharing in macOS, any registered user is able to access their home folder using their own credentials. This works in Catalina, but the special private folders (Documents, Downloads, Desktop) can't be interacted with. Attempts to interact with them result in an 'access denied' error and no dialog is presented to the user on the server machine that would allow access. On the client machine, in both Finder and Terminal these folders simply appear empty and you get a permissions error if you attempt to create a file.

I can see no configuration in either the Security and Privacy settings for these files or in the File Sharing settings that would solve this problem.

How do I allow access to these folders as part of the user's home share over a network in Catalina such that it works as it did in previous versions of macOS?

  • Hi. I contacted Apple some weeks ago and after been leveled up several times I got the answer that Apple is aware of this problematic and that a fix is coming. That was one or two point updates ago ....
    – SEJU
    Commented Feb 3, 2020 at 7:52

1 Answer 1


This is probably a bug. You can solve it by deactivating the file sharing option in the Sharing section of the Preferences window and then reactivating it.

  • Certainly I tried many permutations of disable / re-enable. Nothing has solved it.
    – WillyC
    Commented Feb 3, 2020 at 15:25
  • 1
    I had the same problem since installation of MacOS Catalina. Today I deactivated file sharing and reactivated it and after doing so it worked on two machines which had that issue ...
    – SEJU
    Commented Feb 3, 2020 at 16:10
  • Yep, worked for me, nice one.
    – matt
    Commented Aug 25, 2021 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .