1

I am using MacOS Catalina, and I use iTerm as my terminal. My problem is, that every time iTerm has been closed, and opened again, it only opens in half screen. I know I can drag it down to full screen with my cursor, but it's super annoying if I have to do that every time I open it.

Is there a way to make it full screen by default?

  • Do you mean macOS fullscreen mode? What do you mean by „drag it down“? – n1000 Dec 10 '19 at 12:21
  • macOS fullscreen mode, yes. I drag it down instead of clicking the green circle/button in the top left corner because there is no circle/button. – user353177 Dec 10 '19 at 12:22
0

Yes, go to preferences under the iTerm menu item. When the panel opens, select the Profiles option at the top of the panel. Once that opens, click on the Hotkey Window option, and then click the window tab near the top right. In that window you can define the window size or on the right select instead of Normal, Full Screen. See the image below.

enter image description here

|improve this answer|||||
  • Thanks @jmh, don't forget to say that I need to click on the Hotkey Window tab before clicking on the Windows tab. Upvoted + accepted! – user353177 Dec 10 '19 at 16:36
  • Thank you. I didn't have to press anything. I changed from Normal to Full Screen and restarted iTerm. The window opened in full screen without doing anything else. I'll look into this but don't want to add it until I'm sure it's needed, Thanks again. – jmh Dec 10 '19 at 16:48
  • oh i miss understood your comment. i don't know how to make this doable using hotkey. I was just answering when you asked to make full screen the default. I'm sorry. – jmh Dec 10 '19 at 16:58
  • It's ok, I figured it out. It's the same, but I just have to press that hotkey window before doing the rest. – user353177 Dec 10 '19 at 17:02
  • well, thanks. I'm glad you got things set! – jmh Dec 10 '19 at 18:39

You must log in to answer this question.