Okay so I decided to reinstall Lion on a MacBook Air 11' Mid June/July which my dad gave me after he used it for a while. I restarted using Command + R and erased the Macintosh HD first and then tried the Lion Internet Recovery.

The problem i'm facing is it downloads all the way and then in between/by the end i get this error:

'Additional Components of Lion were unable to download. Please try again.'

Now i wish i hadnt erased my HD first. I've tried it for like 5 times with different connections. Still no luck.

Is there a solution guys? Or is my best bet to take it to the iStore here in India.

Thanks in advance.


If you have access to another computer, you could try downloading the Lion installer from the App Store, right clicking on it and clicking "Show Package Contents" and finding the "InstallESD.dmg" file and restoring this to a flash drive (8GB+). Then you can hold alt on startup and select the drive as your boot option. You should be able to install Lion on the air without needing to download the additional components, but it may still try. Even if it tries, it might still work since you're installing from a different drive. It's worth a shot.

| improve this answer | |
  • Hey Matt, But the other mac i have runs on Lepord and i dont have the app store!!! Any other solution? – Jaimmin Jan 20 '12 at 16:36
  • Thanks for your comment and help. I had tried again, and it worked and took me to the Lion setup page. So glad and happy. Thanks. – Jaimmin Jan 20 '12 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .