1

Before Catalina it was possible to hide username and computer name from terminal window title:

enter image description here

Yet now despite any combination of configuration I'm unable to hide those items from window title: enter image description here

1

The reason for that is because you are running zsh shell. I'm running the bash shell and no name or directory shows up in terminal window name. You can run bash before running terminal and that should give you the window name you want. If you type zsh the terminal name will change back.

I don't have Catalina but I've read its changed initial terminal setting to zsh.

1
  • Yes, I deliberatelly switched to zsh because it's now a default for MacOS, I thought that probably window configuration has nothing to do with version of shell that is used. Dec 9 '19 at 17:45
0
  1. Open the Preferences in the terminal (top right)
  2. Go into the Shell tab
  3. Then copy/paste the command

    export PS1="\W \$"; clear;
    
  4. Uncheck the "Working directory", "Active Process", and everything else under the Title section.

  5. Then restart the terminal and should work. enter image description here enter image description here

The final look will be like this

enter image description here

1
  • This is solution for bash shell, I'm using zsh though Dec 9 '19 at 18:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .