1

I have just installed MacVim on my new Macbook.

But I have a problem: on Linux I was able to scroll through my code—vertically moving my cursor—by using my trackpad. But on Macvim this doesn't work for me.

When scrolling in Macvim, the buffer/window scrolls but the cursor doesn't move.

I made a little video demonstrating the issue: here you see the buffer moving when I scroll using my trackpad, but not my cursor scrolling.

I tried to fix this error by using the command :set mouse=a, but without success. I also took a look at MouseTerm (using SIBML), but this doesn't seem trustworthy and a little bit overkill to just enable good scrolling behavior.

I found a solution which came close:

nnoremap <ScrollWheelUp> k
nnoremap <ScrollWheelDown> j

However, this scrolling is not even close to smooth and I was hoping for a more elegant way to solve this than remapping.

By the way, scrolling does work fine in the normal Vim using the Terminal as long as Mouse Reporting is enabled.

TL;DR: How to enable smooth scrolling behavior with trackpad in Macvim? Thanks!

You must log in to answer this question.

Browse other questions tagged .