0

I have the Zulip desktop app installed on Mojave 10.14.6, and I often cannot open any Zulip windows. When I right-click on the Zulip icon in the dock and select "show all windows", I just see the message "no available windows." I have tried quitting and restarting the app, selecting "unhide" from the menu, reset (cmd-R), hard-reset (shift-cmd-R), and various other menu options (such as toggling which organizations to show), with no effect. I have even restarted my laptop without being able to recover.

I was able to recover the app once by uninstalling and reinstalling, but it soon disappeared again.

Is there any way to fix this in Zulip specifically or other apps in general?

3
  • Go to General Preferences and tick "close windows while closing apps". You might be at an disadvantage if you were using this so far. Also, keep its dmg handy.
    – anki
    Dec 8, 2019 at 16:43
  • @ankii Thanks for the tip; I did already have that enabled, so I toggled it off and on again, then tried quitting and re-opening again. The behavior remained the same. Dec 9, 2019 at 16:58
  • 1
    You might want to use their support channel/ developer forum.
    – anki
    Dec 9, 2019 at 17:31

1 Answer 1

0

Zulip was in "minimized" mode. To show any windows, I needed to click on the tray icon in the upper-right and select one of the menu options.

Tray icon menu

In the Zulip "Settings" menu, the "Always start minimized" option was enabled; I have now disabled it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .