When my original HDD crashed I wanted to change it and choose a Samsung HDD (I don't not the exact model anymore). The problem with this one was that the system often hanged for several seconds until it worked again for a short time. Often the colored spinning wheel appeared and I had to wait. The MacBook Pro was unusable with this.

Then I bought a Hitachi HDD from my colleague that was built in another MacBook an it worked perfectly. There were no problems.

A week ago I decided to put in the Crucial M4 SSD with 128 GB. The same problem as with the Samsung HDD. I've cloned my old HDD, reinstalled the system, but nothing helped. Even the re-installation took me several hours, not as usual. I've also upgraded the Crucial HDD to the newest firmware without any success.

  • Why does this happens or does somebody have any idea to get the SSD working?
  • Was it just coincidence that the Hitachi HDD worked and the other two didn't?
  • I got the exact same problem. It really pisses me off. Also, no entries in the console.
    – gentmatt
    Commented Jan 20, 2012 at 11:13
  • I have an crucial m4 with the latest firmware (0309) and formatted for single boot.
    – gentmatt
    Commented Jan 20, 2012 at 11:16
  • Thought I'm the only one. I have the exact same firmware.
    – MoFuRo
    Commented Jan 20, 2012 at 11:26

4 Answers 4


Is your MacBook Pro the MacBook Pro (15-inch, 2.53GHz, Mid 2009) model? That model of MBP had a known issue where it would constantly beach-ball with non Apple drives. There was a firmware update available but that hasn't fixed all units.

From personal (and professional) experience I've found upgrading to Mac OS X Snow Leopard 10.6 fixed about 50% of the time, all other units had to have an official Apple drive fitted to fix the issue.

Basically your only options are to upgrade to Snow Leopard (I'm unsure of whether Lion includes the relevant firmware updates) or complain to Apple so much that they give you a replacement unit. Ugh.

  • This is the model I have. So I think it sounds bad. I will write the support or call them.
    – MoFuRo
    Commented Jan 20, 2012 at 11:30
  • I got the MBP 3,1 (late 2007) running lion 10.7.2. I doubt I'll get a replacement unit :-)
    – gentmatt
    Commented Jan 20, 2012 at 11:36
  • 1
    Today I've tested the SSD on an 13" Macbook Mid 2007. Everything worked perfect. So sad that there is such a difference between the devices.
    – MoFuRo
    Commented Jan 20, 2012 at 13:55

This is a common know issue that Apple has not acknowledged. Google: "Macbook Pro 2009 EFI firmware update 1.7."

Downgrade the motherboard firmware back to EFI 1.6. (you may not be able to upgrade to Mountain Lion however.

See the discussion here: https://discussions.apple.com/thread/2267098?start=0&tstart=0

The following has someone else's instructions but I updated link to a non-broken one for the firmware file.

The following is my take on the Russian instructions, which I tested and confirmed they worked.

  1. Download the linked .dmg file. http://hotfile.com/dl/109001076/5dfaf39/aluminum.macbook.pro.recovery.dmg.html
  2. Do not mount file
  3. Plug in a usb drive any size
  4. REformat this USB drive in Mac OSX HFS+ Journaled in disk utility.
  5. Click on the newly formatted drive Volume, then click on the tab restore (same row as erase).
  6. In this panel you will see two white input boxes, in source you will browse and select the .dmg downloaded in step 1, you can either brose it or drag and drop it in the source bow.
  7. In the Destination box, drag and drop the newly formatted Volume from step 4/5.
    • no need to have the erase destination box checked/ticked.
  8. Hit the restore button.
  9. Once this is done, unplug and replug the usb drive, shut down the machine
  10. Boot up the machine while its booting up, before the apple icon pops up, press and hold the option button until your drives/partitions pop up.
  11. In my case I had three pop up, my Bootcamp partition my main Mac harddrive, and the BOOTABLE USB drive I just made. Select the bootable USB drive (yellow orangish color), Use Arrows to navigate and Enter button to select.

  12. Once this is selected the Apple logo will come up and a dark gray bar will start to move right under it. Sit, relax, and wait for the process to be done.

END: you have now downgraded to EFI firmware 1.6

If you get this error:

"Image Error:

Could not find any scan information. The source image needs to be imagescanned before it can be restored."

Click on the image file in the list on the left and then click on Image in the menu and then on Scan Image for Restore. After that, everything should go smoothly.

Thanks to SmAcDuff for pointing out the solution to the Image scan error.

  • The linked DMG file is gone. Does anybody have a copy to share?
    – meustrus
    Commented Sep 29, 2013 at 20:01
  • I figured out how to do this without the linked file and shared the steps, for anybody else who wants to try.
    – meustrus
    Commented Jan 16, 2014 at 13:58

Some people have replaced the cable with a thicker 2010 modle and reported that it fixed the problem. It didn't help me though.

oversized cable http://www.applepalace.com/scripts/prodView.asp?idproduct=10013

The other option is to connect the appropriate jumper pins with a jumper shunt they call it. that is supposed to physically limit the speed to sata1 (1.5gbs) I'm going to try that in a few days when I get them.

NEW HARD DRIVE that is reported to have worked for a few people. http://eshop.macsales.com/item/HGST/0J22413S2/


I had this problem with my mid-2009 MBP after upgrading to a Crucial 500GB SSD. With the OS version I was running (I think it was Mountain Lion) it was very bad, beachballing constantly. I upgraded to Yosemite and it got a bit better, working smoothly for 10-20 minutes or so after start-up before starting to beach ball (heat issue??), but it was still pretty unusable for anything serious. I was on EFI 1.7 and trying to revert to 1.6 didn't seem like the way to go. Finally, I tried swapping out the Crucial for a Samsung 850 EVO 1TB SSD and I'm happy to report--no more beachballs! It's working great!

For what it's worth, I did make an unsuccessful attempt at updating the firmware on the Crucial before giving up on it. The Crucial website has a link for how to do this on a mac, but the supposed mac instructions also seem oriented towards PC users. I did my best to interpret them to make a bootable USB drive with the firmware update image, but it's a DOS-based utility and didn't show signs of actually doing something, no text printed on the screen, etc.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .