1

Sometimes I want my Mac OS time to be different from my local time zone. In order to do that I uncheck the box "set time and date automatically" and set the time to whatever I want. This works beautifully for quite some time (days) until randomly something resets the time back to the local timezone. The box with the settings is still unchecked, but clearly some process has set the time automatically to the local one. What is this process & how can I stop it from happening?

I am currently running Mac OS 10.14, but I think this issue also occurred on previous versions of Mac OS. My computer is a Macbook Air in case it matters.

[I also have the box "set time zone automatically using current location" unchecked, but I have manually selected the time-zone I am in.]

| improve this question | | | | |
  • When you change the time to some other location on the planet, do you also set the computer to be in the same time zone? – IconDaemon Dec 5 '19 at 15:38
  • No, I don't. My local time-zone is set according to my actual location. My computer time is set different from that time-zone. – user2705196 Dec 5 '19 at 15:41
  • macOS must periodically reset the time to the time it should be in the time zone selected based on the time you set manually. I can't find any documentation about this, but it seems to be a reasonable assumption. I'd try changing the time zone on the Mac to the time zone you're setting the Mac to via the manual time change. Worth a try. – IconDaemon Dec 5 '19 at 15:44
  • Thanks for the suggestion! Ideally, I'd like to avoid adjusting my time-zone because I want to avoid knock on effects effects that has, e.g. on calendar entries... – user2705196 Dec 5 '19 at 15:45
1

You can try blocking outgoing connections to UDP port 123 (NTP) with a PF firewall rule such as:

block drop out quick proto udp from any to any port 123

I'm no PF expert, YMMV.

See here for details on how to apply the rule: https://apple.stackexchange.com/a/230556/134740

| improve this answer | | | | |
  • Are you sure this is an answer to my question? – user2705196 Dec 6 '19 at 0:33
  • There is no way I can be sure : ) I suspect the "timed" daemon is running in the background and causing that change of time. I did some research online and it seems this can happen even with your settings. That firewall rule should prevent its access to any NTP server (even local to your network). Are you concerned about testing it? It's easy to undo if it doesn't help... – Kamal Dec 7 '19 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .