alt text

It still seems to sync most things - the error occurs late in the sync toward the end of the last step, which seems to be photo-related, and my apps are up to date, etc.

The main thing I've noticed that's off is my pictures - when I open the pictures app, I get a message saying:

iTunes Sync Needed - High Resolution images synced via itunes are missing. Connect your device to the computer you sync photos from and launch iTunes to sync them.

Since the issue seems like it might be photo-related, I tried repairing my Aperture library's permissions and database - no help.

Any ideas?

  • @Kyle, that worked- thanks! (Although it makes me feel a little like the guy who calls support without restarting.) Care to make it an answer, so I can accept it, and the next person who runs into it will find the right solution?
    – Jaydles
    Nov 10, 2010 at 4:03
  • ok, done, glad it worked for you Nov 10, 2010 at 4:14

1 Answer 1


Try turning off photo sync completely, syncing, and then turning it back on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .